aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7628.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7628.mk')
-rw-r--r--target/linux/ramips/image/mt7628.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7628.mk b/target/linux/ramips/image/mt7628.mk
index f8bd2c18b2..fbfc37d986 100644
--- a/target/linux/ramips/image/mt7628.mk
+++ b/target/linux/ramips/image/mt7628.mk
@@ -2,6 +2,8 @@
# MT7628 Profiles
#
+DEVICE_VARS += TPLINK_BOARD_ID
+
define Device/mt7628
DTS := MT7628
BLOCKSIZE := 64k
@@ -26,6 +28,28 @@ define Device/miwifi-nano
endef
TARGET_DEVICES += miwifi-nano
+define Device/tl-wr840n-v4
+ DTS := TL-WR840NV4
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-Link TL-WR840N v4
+ TPLINK_BOARD_ID := TL-WR840NV4
+ KERNEL := $(KERNEL_DTB)
+ IMAGES += tftp-recovery.bin
+ IMAGE/factory.bin := tplink-v2-image
+ IMAGE/tftp-recovery.bin := pad-extra 128k | $$(IMAGE/factory.bin)
+ IMAGE/sysupgrade.bin := tplink-v2-image -s | append-metadata | \
+ check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += tl-wr840n-v4
+
+define Device/tl-wr841n-v13
+ $(Device/tl-wr840n-v4)
+ DTS := TL-WR841NV13
+ DEVICE_TITLE := TP-Link TL-WR841N v13
+ TPLINK_BOARD_ID := TL-WR841NV13
+endef
+TARGET_DEVICES += tl-wr841n-v13
+
define Device/gl-mt300n-v2
DTS := GL-MT300N-V2
IMAGE_SIZE := 16064k