aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk34
1 files changed, 22 insertions, 12 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 728b2efb24..9103fd6762 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -957,6 +957,27 @@ define Device/wevo_w2914ns-v2
endef
TARGET_DEVICES += wevo_w2914ns-v2
+define Device/xiaomi-ac2100
+ $(Device/uimage-lzma-loader)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 120320k
+ UBINIZE_OPTS := -E 5
+ IMAGES += kernel1.bin rootfs0.bin
+ IMAGE/kernel1.bin := append-kernel
+ IMAGE/rootfs0.bin := append-ubi | check-size
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ DEVICE_VENDOR := Xiaomi
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware wpad-basic uboot-envtools
+endef
+
+define Device/xiaomi_mi-router-ac2100
+ $(Device/xiaomi-ac2100)
+ DEVICE_MODEL := Mi Router AC2100
+endef
+TARGET_DEVICES += xiaomi_mi-router-ac2100
+
define Device/xiaomi_mir3g
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
@@ -1009,19 +1030,8 @@ endef
TARGET_DEVICES += xiaomi_mir3p
define Device/xiaomi_redmi-router-ac2100
- $(Device/uimage-lzma-loader)
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- KERNEL_SIZE := 4096k
- IMAGE_SIZE := 124416k
- UBINIZE_OPTS := -E 5
- IMAGES += kernel1.bin rootfs0.bin
- IMAGE/kernel1.bin := append-kernel
- IMAGE/rootfs0.bin := append-ubi | check-size
- IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- DEVICE_VENDOR := Xiaomi
+ $(Device/xiaomi-ac2100)
DEVICE_MODEL := Redmi Router AC2100
- DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware wpad-basic uboot-envtools
endef
TARGET_DEVICES += xiaomi_redmi-router-ac2100