aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index f2ca2a971d..fd40b6f0a6 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2005,6 +2005,31 @@ define Device/tplink_eap615-wall-v1
endef
TARGET_DEVICES += tplink_eap615-wall-v1
+define Device/tplink_ec330-g5u-v1
+ $(Device/dsa-migration)
+ LOADER := bin
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ UBINIZE_OPTS := -E 5
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 49152k
+ DEVICE_VENDOR := TP-Link
+ DEVICE_MODEL := EC330-G5u
+ DEVICE_ALT0_VENDOR := TP-Link
+ DEVICE_ALT0_MODEL := Archer C9ERT
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-mt7615-firmware kmod-usb-ledtrig-usbport \
+ kmod-usb3 uboot-envtools
+ KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | \
+ uImage-tplink-c9 standalone '$(call toupper,$(LINUX_KARCH)) \
+ $(VERSION_DIST) Linux-$(LINUX_VERSION)' | \
+ uImage-tplink-c9 firmware 'OS IMAGE ($(VERSION_DIST))'
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | \
+ uImage none
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata | check-size
+endef
+TARGET_DEVICES += tplink_ec330-g5u-v1
+
define Device/tplink_er605-v2
$(Device/dsa-migration)
DEVICE_VENDOR := TP-Link