aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 3ecd4ba3a1..bbf3f65830 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -79,6 +79,18 @@ define Device/wn3000rpv3
endef
TARGET_DEVICES += wn3000rpv3
+define Device/ex3700
+ NETGEAR_BOARD_ID := U12H319T00_NETGEAR
+ DTS := EX3700
+ BLOCKSIZE := 4k
+ IMAGE_SIZE := 7744k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | netgear-chk
+ DEVICE_PACKAGES := -kmod-mt76 kmod-mt76x2
+ DEVICE_TITLE := Netgear EX3700
+endef
+TARGET_DEVICES += ex3700
+
define Device/wt3020-4M
DTS := WT3020-4M
BLOCKSIZE := 4k