aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/common-tp-link.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/common-tp-link.mk')
-rw-r--r--target/linux/ramips/image/common-tp-link.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ramips/image/common-tp-link.mk b/target/linux/ramips/image/common-tp-link.mk
index 07ad1ea250..915a086f98 100644
--- a/target/linux/ramips/image/common-tp-link.mk
+++ b/target/linux/ramips/image/common-tp-link.mk
@@ -11,8 +11,8 @@ define Device/tplink-v1
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v1-header -e -O
IMAGES += factory.bin
IMAGE/factory.bin := tplink-v1-image factory -e -O
- IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade -e -O | append-metadata | \
- check-size
+ IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade -e -O | check-size | \
+ append-metadata
endef
define Device/tplink-v2
@@ -26,8 +26,8 @@ define Device/tplink-v2
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v2-header -e
IMAGES += factory.bin
IMAGE/factory.bin := tplink-v2-image -e
- IMAGE/sysupgrade.bin := tplink-v2-image -s -e | append-metadata | \
- check-size
+ IMAGE/sysupgrade.bin := tplink-v2-image -s -e | check-size | \
+ append-metadata
endef
define Device/tplink-safeloader
@@ -39,6 +39,6 @@ define Device/tplink-safeloader
KERNEL := $(KERNEL_DTB) | tplink-v1-header -e -O
IMAGES += factory.bin
IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
- append-metadata | check-size
+ check-size | append-metadata
IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
endef