aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/common-tp-link.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/common-tp-link.mk')
-rw-r--r--target/linux/ramips/image/common-tp-link.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/common-tp-link.mk b/target/linux/ramips/image/common-tp-link.mk
index 915a086f98..cb26275960 100644
--- a/target/linux/ramips/image/common-tp-link.mk
+++ b/target/linux/ramips/image/common-tp-link.mk
@@ -1,6 +1,19 @@
DEVICE_VARS += TPLINK_FLASHLAYOUT TPLINK_HWID TPLINK_HWREV TPLINK_HWREVADD
DEVICE_VARS += TPLINK_HVERSION TPLINK_BOARD_ID TPLINK_HEADER_VERSION
+define Build/uImage-tplink-c9
+ mkimage \
+ -A $(LINUX_KARCH) \
+ -O linux \
+ -T $(word 1,$(1)) \
+ -C none \
+ -a $(KERNEL_LOADADDR) \
+ -e $(KERNEL_LOADADDR) \
+ -n $(wordlist 2,$(words $(1)),$(1)) \
+ -d $@ $@.new
+ mv $@.new $@
+endef
+
define Device/tplink-v1
DEVICE_VENDOR := TP-Link
TPLINK_FLASHLAYOUT :=