aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/qoriq/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/qoriq/image/Makefile')
-rw-r--r--target/linux/qoriq/image/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/qoriq/image/Makefile b/target/linux/qoriq/image/Makefile
new file mode 100644
index 0000000000..a3c8dd38c2
--- /dev/null
+++ b/target/linux/qoriq/image/Makefile
@@ -0,0 +1,36 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+SQUASHFSCOMP := xz $(LZMA_XZ_OPTIONS)
+
+define Build/sdcard-img
+ rm -fR $@.boot
+ mkdir -p $@.boot
+ $(CP) $(KDIR)/$(DEVICE_NAME)-kernel.bin $@.boot
+ $(if $(DEVICE_DTS),\
+ $(foreach dtb,$(DEVICE_DTS),$(CP) $(KDIR)/image-$(dtb).dtb $@.boot), \
+ $(CP) $(KDIR)/image-/*.dtb $@.boot)
+
+ $(SCRIPT_DIR)/gen_image_generic.sh \
+ $@ \
+ $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS) \
+ 2048
+
+ $(if $(UBOOT),dd if=$(STAGING_DIR_IMAGE)/$(UBOOT).img of=$@ bs=512 skip=1 seek=1 conv=notrunc)
+endef
+
+define Device/Default
+ PROFILES := Default
+ DEVICE_DTS := $(subst _,-,$(1))
+ KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
+ KERNEL_ENTRY := 0x00000000
+ KERNEL_LOADADDR := 0x00000000
+ KERNEL := kernel-bin
+endef
+
+include $(SUBTARGET).mk
+
+$(eval $(call BuildImage))