aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/qoriq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/qoriq/Makefile')
-rw-r--r--target/linux/qoriq/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/qoriq/Makefile b/target/linux/qoriq/Makefile
new file mode 100644
index 0000000000..2dc08afd8c
--- /dev/null
+++ b/target/linux/qoriq/Makefile
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2021 Stijn Tintel <stijn@linux-ipv6.be>
+
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc64
+BOARD:=qoriq
+BOARDNAME:=NXP QorIQ (PowerPC)
+CPU_TYPE:=e5500
+FEATURES:=boot-part ext4 fpu legacy-sdcard powerpc64 ramdisk root-part rtc source-only
+SUBTARGETS:=generic
+
+KERNEL_PATCHVER:=5.10
+
+KERNELNAME:=zImage
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += e2fsprogs mkf2fs uboot-envtools
+
+$(eval $(call BuildTarget))