aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxa/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/pxa/image/Makefile')
-rw-r--r--target/linux/pxa/image/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/pxa/image/Makefile b/target/linux/pxa/image/Makefile
index 74edb62be0..7f2b5d4123 100644
--- a/target/linux/pxa/image/Makefile
+++ b/target/linux/pxa/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,8 +15,20 @@ define Image/BuildKernel
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
endef
+# Build a fake flash image for usage in Qemu
+define Image/Build/Gumstix
+ dd if=/dev/zero bs=128k count=256 of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+ dd if=$(BIN_DIR)/openwrt-pxa-gumstix-u-boot.bin conv=notrunc bs=128k \
+ of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+ dd if=$(KDIR)/root.$(1) conv=notrunc bs=128k seek=2 \
+ of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+ dd if=$(KDIR)/uImage conv=notrunc bs=128k seek=248 \
+ of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
+ $(call Image/Build/$(PROFILE),$(1))
endef
define Image/Build/jffs2-64k