aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc44x/patches-3.18
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ppc44x/patches-3.18')
-rw-r--r--target/linux/ppc44x/patches-3.18/001-crypto-amcc-remove-incorrect-__init-__exit-markups.patch46
-rw-r--r--target/linux/ppc44x/patches-3.18/100-openwrt_flashmap.patch55
-rw-r--r--target/linux/ppc44x/patches-3.18/110-openwrt_dts_cmdline.patch9
-rw-r--r--target/linux/ppc44x/patches-3.18/900-bootwrapper-parallel-make-fix.patch45
4 files changed, 0 insertions, 155 deletions
diff --git a/target/linux/ppc44x/patches-3.18/001-crypto-amcc-remove-incorrect-__init-__exit-markups.patch b/target/linux/ppc44x/patches-3.18/001-crypto-amcc-remove-incorrect-__init-__exit-markups.patch
deleted file mode 100644
index 09b6523dca..0000000000
--- a/target/linux/ppc44x/patches-3.18/001-crypto-amcc-remove-incorrect-__init-__exit-markups.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 1eb8a1b340e2f0a562b4987683bbaee4d620bf0a Mon Sep 17 00:00:00 2001
-From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
-Date: Mon, 9 Mar 2015 13:35:39 -0700
-Subject: [PATCH] crypto: amcc - remove incorrect __init/__exit markups
-
-Even if bus is not hot-pluggable, the devices can be bound and unbound
-from the driver via sysfs, so we should not be using __init/__exit
-annotations on probe() and remove() methods. The only exception is
-drivers registered with platform_driver_probe() which specifically
-disables sysfs bind/unbind attributes.
-
-Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
-Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
----
- drivers/crypto/amcc/crypto4xx_core.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
---- a/drivers/crypto/amcc/crypto4xx_core.c
-+++ b/drivers/crypto/amcc/crypto4xx_core.c
-@@ -1155,7 +1155,7 @@ struct crypto4xx_alg_common crypto4xx_al
- /**
- * Module Initialization Routine
- */
--static int __init crypto4xx_probe(struct platform_device *ofdev)
-+static int crypto4xx_probe(struct platform_device *ofdev)
- {
- int rc;
- struct resource res;
-@@ -1263,7 +1263,7 @@ err_alloc_dev:
- return rc;
- }
-
--static int __exit crypto4xx_remove(struct platform_device *ofdev)
-+static int crypto4xx_remove(struct platform_device *ofdev)
- {
- struct device *dev = &ofdev->dev;
- struct crypto4xx_core_device *core_dev = dev_get_drvdata(dev);
-@@ -1292,7 +1292,7 @@ static struct platform_driver crypto4xx_
- .of_match_table = crypto4xx_match,
- },
- .probe = crypto4xx_probe,
-- .remove = __exit_p(crypto4xx_remove),
-+ .remove = crypto4xx_remove,
- };
-
- module_platform_driver(crypto4xx_driver);
diff --git a/target/linux/ppc44x/patches-3.18/100-openwrt_flashmap.patch b/target/linux/ppc44x/patches-3.18/100-openwrt_flashmap.patch
deleted file mode 100644
index 5a0295ea7b..0000000000
--- a/target/linux/ppc44x/patches-3.18/100-openwrt_flashmap.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/arch/powerpc/boot/dts/taishan.dts
-+++ b/arch/powerpc/boot/dts/taishan.dts
-@@ -194,16 +194,12 @@
- #address-cells = <1>;
- #size-cells = <1>;
- partition@0 {
-- label = "kernel";
-- reg = <0x0 0x180000>;
-+ label = "firmware";
-+ reg = <0x0 0x3e00000>;
- };
-- partition@180000 {
-- label = "root";
-- reg = <0x180000 0x200000>;
-- };
-- partition@380000 {
-- label = "user";
-- reg = <0x380000 0x3bc0000>;
-+ partition@3e00000 {
-+ label = "diagnostics";
-+ reg = <0x3e00000 0x140000>;
- };
- partition@3f40000 {
- label = "env";
---- a/arch/powerpc/boot/dts/canyonlands.dts
-+++ b/arch/powerpc/boot/dts/canyonlands.dts
-@@ -222,24 +222,12 @@
- #address-cells = <1>;
- #size-cells = <1>;
- partition@0 {
-- label = "kernel";
-- reg = <0x00000000 0x001e0000>;
-- };
-- partition@1e0000 {
-- label = "dtb";
-- reg = <0x001e0000 0x00020000>;
-+ label = "kernel+dtb";
-+ reg = <0x00000000 0x00200000>;
- };
- partition@200000 {
-- label = "ramdisk";
-- reg = <0x00200000 0x01400000>;
-- };
-- partition@1600000 {
-- label = "jffs2";
-- reg = <0x01600000 0x00400000>;
-- };
-- partition@1a00000 {
-- label = "user";
-- reg = <0x01a00000 0x02560000>;
-+ label = "rootfs";
-+ reg = <0x00200000 0x03d60000>;
- };
- partition@3f60000 {
- label = "env";
diff --git a/target/linux/ppc44x/patches-3.18/110-openwrt_dts_cmdline.patch b/target/linux/ppc44x/patches-3.18/110-openwrt_dts_cmdline.patch
deleted file mode 100644
index bcf18718e9..0000000000
--- a/target/linux/ppc44x/patches-3.18/110-openwrt_dts_cmdline.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/arch/powerpc/boot/dts/taishan.dts
-+++ b/arch/powerpc/boot/dts/taishan.dts
-@@ -419,5 +419,6 @@
-
- chosen {
- linux,stdout-path = "/plb/opb/serial@40000300";
-+ bootargs = "rootfstype=squashfs noinitrd";
- };
- };
diff --git a/target/linux/ppc44x/patches-3.18/900-bootwrapper-parallel-make-fix.patch b/target/linux/ppc44x/patches-3.18/900-bootwrapper-parallel-make-fix.patch
deleted file mode 100644
index 313347ceaf..0000000000
--- a/target/linux/ppc44x/patches-3.18/900-bootwrapper-parallel-make-fix.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From: Jo-Philipp Wich <jo@mein.io>
-Date: Wed, 4 Jan 2017 10:35:00 +0100
-Subject: [PATCH] powerpc: boot: fix build with parallel make
-
-The powerpc boot wrapper Makefile is not parallel build safe, causing fixdep
-to fail reading dependency files of the addnote, hack-coff and mktree
-utilities when concurrently building different image targets.
-
-A typical failure looks like:
-
- Building modules, stage 2.
- HOSTCC arch/powerpc/boot/addnote
- HOSTCC arch/powerpc/boot/hack-coff
- DTC arch/powerpc/boot/taishan.dtb
- HOSTCC arch/powerpc/boot/addnote
- HOSTCC arch/powerpc/boot/hack-coff
- MODPOST 800 modules
- fixdep: error opening depfile: arch/powerpc/boot/.hack-coff.d: No such file or directory
- scripts/Makefile.host:91: recipe for target 'arch/powerpc/boot/hack-coff' failed
- make[5]: *** [arch/powerpc/boot/hack-coff] Error 2
- make[5]: *** Waiting for unfinished jobs....
- fixdep: error opening depfile: arch/powerpc/boot/.addnote.d: No such file or directory
- scripts/Makefile.host:91: recipe for target 'arch/powerpc/boot/addnote' failed
- make[5]: *** [arch/powerpc/boot/addnote] Error 2
- rm arch/powerpc/boot/taishan.dtb
- arch/powerpc/Makefile:263: recipe for target 'cuImage.taishan' failed
- make[4]: *** [cuImage.taishan] Error 2
- make[4]: *** Waiting for unfinished jobs....
-
-Add a GNU make specific .NOTPARALLEL pseudo rule to enforce sequential building
-of the addnote, hack-coff and mktree executables.
-
-Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-
---- a/arch/powerpc/boot/Makefile
-+++ b/arch/powerpc/boot/Makefile
-@@ -194,6 +194,8 @@ wrapper :=$(srctree)/$(src)/wrapper
- wrapperbits := $(extra-y) $(addprefix $(obj)/,addnote hack-coff mktree) \
- $(wrapper) FORCE
-
-+.NOTPARALLEL: $(addprefix $(obj)/,addnote hack-coff mktree) $(wrapper)
-+
- #############
- # Bits for building various flavours of zImage
-