aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap35xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/omap35xx/image/Makefile')
-rw-r--r--target/linux/omap35xx/image/Makefile32
1 files changed, 0 insertions, 32 deletions
diff --git a/target/linux/omap35xx/image/Makefile b/target/linux/omap35xx/image/Makefile
deleted file mode 100644
index e742b75e4b..0000000000
--- a/target/linux/omap35xx/image/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-JFFS2_BLOCKSIZE=128k
-JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
-
-UBIFS_OPTS = -m 2048 -e 126KiB -c 1996 -U
-UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
-
-define Image/BuildKernel
- $(TARGET_CROSS)objcopy -O binary -R .note -R .comment -S $(LINUX_DIR)/arch/arm/boot/compressed/vmlinux linux.bin
- mkimage -A arm -O linux -T kernel -C none -a 80008000 -e 80008000 -n "OpenWRT Kernel Image gumstix" -d linux.bin uImage
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'uImage.bin+mmc2' -d ../files/boot-mmc.cmd boot.scr
-
- mv uImage $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-uImage
- mv boot.scr $(BIN_DIR)/boot.scr
- rm linux.bin
-endef
-
-define Image/Build
- $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-root.$(1)
-# PADDING="true" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).image 4 $(KDIR)/root.bootscript 240 $(KDIR)/root.$(1)
- $(call Image/Build/$(1),$(1))
-endef
-
-$(eval $(call BuildImage))