aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a53.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image/cortex-a53.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk12
1 files changed, 2 insertions, 10 deletions
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
index dd6176100b..a102f52481 100644
--- a/target/linux/mvebu/image/cortex-a53.mk
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -1,25 +1,17 @@
ifeq ($(SUBTARGET),cortexa53)
define Device/globalscale-espressobin
- KERNEL_NAME := Image
- KERNEL := kernel-bin
+ $(call Device/Default-arm64)
DEVICE_TITLE := ESPRESSObin (Marvell Armada 3700 Community Board)
- IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-3720-espressobin
- DTS_DIR := $(DTS_DIR)/marvell
SUPPORTED_DEVICES := globalscale,espressobin
endef
TARGET_DEVICES += globalscale-espressobin
define Device/armada-3720-db
- KERNEL_NAME := Image
- KERNEL := kernel-bin
+ $(call Device/Default-arm64)
DEVICE_TITLE := Marvell Armada 3720 Development Board DB-88F3720-DDR3
- IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-3720-db
- DTS_DIR := $(DTS_DIR)/marvell
SUPPORTED_DEVICES := marvell,armada-3720-db
endef
TARGET_DEVICES += armada-3720-db