aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a53.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image/cortex-a53.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
new file mode 100644
index 0000000000..711d2c0be8
--- /dev/null
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -0,0 +1,16 @@
+ifeq ($(SUBTARGET),cortexa53)
+
+define Device/globalscale-espressobin
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+ DEVICE_TITLE := ESPRESSObin (Marvell Armada 3700 Community Board)
+ DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-usb2 kmod-usb3 kmod-usb-storage
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+ DEVICE_DTS := armada-3720-espressobin
+ DTS_DIR := $(DTS_DIR)/marvell
+ SUPPORTED_DEVICES := globalscale,espressobin
+endef
+TARGET_DEVICES += globalscale-espressobin
+
+endif