aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.14/0002-MIPS-lantiq-dtb-image-hack.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/patches-3.14/0002-MIPS-lantiq-dtb-image-hack.patch')
-rw-r--r--target/linux/lantiq/patches-3.14/0002-MIPS-lantiq-dtb-image-hack.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/target/linux/lantiq/patches-3.14/0002-MIPS-lantiq-dtb-image-hack.patch b/target/linux/lantiq/patches-3.14/0002-MIPS-lantiq-dtb-image-hack.patch
new file mode 100644
index 0000000000..0b23afe06b
--- /dev/null
+++ b/target/linux/lantiq/patches-3.14/0002-MIPS-lantiq-dtb-image-hack.patch
@@ -0,0 +1,49 @@
+From 17348293f7f8103c97c8d2a6b0ef36eae06ec371 Mon Sep 17 00:00:00 2001
+From: John Crispin <blogic@openwrt.org>
+Date: Wed, 13 Mar 2013 09:36:16 +0100
+Subject: [PATCH 02/31] MIPS: lantiq: dtb image hack
+
+Signed-off-by: John Crispin <blogic@openwrt.org>
+---
+ arch/mips/lantiq/Makefile | 2 --
+ arch/mips/lantiq/prom.c | 4 +++-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/arch/mips/lantiq/Makefile b/arch/mips/lantiq/Makefile
+index d6bdc57..690257a 100644
+--- a/arch/mips/lantiq/Makefile
++++ b/arch/mips/lantiq/Makefile
+@@ -6,8 +6,6 @@
+
+ obj-y := irq.o clk.o prom.o
+
+-obj-y += dts/
+-
+ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
+
+ obj-$(CONFIG_SOC_TYPE_XWAY) += xway/
+diff --git a/arch/mips/lantiq/prom.c b/arch/mips/lantiq/prom.c
+index 19686c5..202e118 100644
+--- a/arch/mips/lantiq/prom.c
++++ b/arch/mips/lantiq/prom.c
+@@ -58,6 +58,8 @@ static void __init prom_init_cmdline(void)
+ }
+ }
+
++extern struct boot_param_header __image_dtb;
++
+ void __init plat_mem_setup(void)
+ {
+ ioport_resource.start = IOPORT_RESOURCE_START;
+@@ -71,7 +73,7 @@ void __init plat_mem_setup(void)
+ * Load the builtin devicetree. This causes the chosen node to be
+ * parsed resulting in our memory appearing
+ */
+- __dt_setup_arch(&__dtb_start);
++ __dt_setup_arch(&__image_dtb);
+ }
+
+ void __init device_tree_init(void)
+--
+1.7.10.4
+