aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.0/540-dev-leds-gpio.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/patches-3.0/540-dev-leds-gpio.patch')
-rw-r--r--target/linux/lantiq/patches-3.0/540-dev-leds-gpio.patch95
1 files changed, 0 insertions, 95 deletions
diff --git a/target/linux/lantiq/patches-3.0/540-dev-leds-gpio.patch b/target/linux/lantiq/patches-3.0/540-dev-leds-gpio.patch
deleted file mode 100644
index a66dc0d858..0000000000
--- a/target/linux/lantiq/patches-3.0/540-dev-leds-gpio.patch
+++ /dev/null
@@ -1,95 +0,0 @@
---- /dev/null
-+++ b/arch/mips/include/asm/mach-lantiq/dev-leds-gpio.h
-@@ -0,0 +1,21 @@
-+/*
-+ * Lantiq GPIO LED device support
-+ *
-+ * Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
-+ * Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
-+ *
-+ * This program is free software; you can redistribute it and/or modify it
-+ * under the terms of the GNU General Public License version 2 as published
-+ * by the Free Software Foundation.
-+ */
-+
-+#ifndef _LANTIQ_DEV_LEDS_GPIO_H
-+#define _LANTIQ_DEV_LEDS_GPIO_H
-+
-+#include <linux/leds.h>
-+
-+void ltq_add_device_leds_gpio(int id,
-+ unsigned num_leds,
-+ struct gpio_led *leds) __init;
-+
-+#endif /* _LANTIQ_DEV_LEDS_GPIO_H */
---- /dev/null
-+++ b/arch/mips/lantiq/dev-leds-gpio.c
-@@ -0,0 +1,57 @@
-+/*
-+ * Lantiq GPIO LED device support
-+ *
-+ * Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
-+ * Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
-+ *
-+ * Parts of this file are based on Atheros' 2.6.15 BSP
-+ *
-+ * This program is free software; you can redistribute it and/or modify it
-+ * under the terms of the GNU General Public License version 2 as published
-+ * by the Free Software Foundation.
-+ */
-+
-+#include <linux/init.h>
-+#include <linux/slab.h>
-+#include <linux/platform_device.h>
-+
-+#include "dev-leds-gpio.h"
-+
-+void __init ltq_add_device_leds_gpio(int id, unsigned num_leds,
-+ struct gpio_led *leds)
-+{
-+ struct platform_device *pdev;
-+ struct gpio_led_platform_data pdata;
-+ struct gpio_led *p;
-+ int err;
-+
-+ p = kmalloc(num_leds * sizeof(*p), GFP_KERNEL);
-+ if (!p)
-+ return;
-+
-+ memcpy(p, leds, num_leds * sizeof(*p));
-+
-+ pdev = platform_device_alloc("leds-gpio", id);
-+ if (!pdev)
-+ goto err_free_leds;
-+
-+ memset(&pdata, 0, sizeof(pdata));
-+ pdata.num_leds = num_leds;
-+ pdata.leds = p;
-+
-+ err = platform_device_add_data(pdev, &pdata, sizeof(pdata));
-+ if (err)
-+ goto err_put_pdev;
-+
-+ err = platform_device_add(pdev);
-+ if (err)
-+ goto err_put_pdev;
-+
-+ return;
-+
-+err_put_pdev:
-+ platform_device_put(pdev);
-+
-+err_free_leds:
-+ kfree(p);
-+}
---- a/arch/mips/lantiq/Makefile
-+++ b/arch/mips/lantiq/Makefile
-@@ -4,7 +4,7 @@
- # under the terms of the GNU General Public License version 2 as published
- # by the Free Software Foundation.
-
--obj-y := irq.o setup.o clk.o prom.o devices.o
-+obj-y := irq.o setup.o clk.o prom.o devices.o dev-leds-gpio.o
-
- obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
-