aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/tp-link.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/image/tp-link.mk')
-rw-r--r--target/linux/lantiq/image/tp-link.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/tp-link.mk b/target/linux/lantiq/image/tp-link.mk
index cebdf46e12..e269aacd02 100644
--- a/target/linux/lantiq/image/tp-link.mk
+++ b/target/linux/lantiq/image/tp-link.mk
@@ -1,5 +1,10 @@
DEVICE_VARS += TPLINK_FLASHLAYOUT TPLINK_HWID TPLINK_HWREV TPLINK_HWREVADD TPLINK_HVERSION
+define Device/dsa-migration
+ DEVICE_COMPAT_VERSION := 1.1
+ DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
+endef
+
define Device/lantiqTpLink
DEVICE_VENDOR := TP-Link
TPLINK_HWREVADD := 0
@@ -13,6 +18,7 @@ define Device/lantiqTpLink
endef
define Device/tplink_tdw8970
+ $(Device/dsa-migration)
$(Device/lantiqTpLink)
DEVICE_MODEL := TD-W8970
DEVICE_VARIANT := v1
@@ -26,6 +32,7 @@ endef
TARGET_DEVICES += tplink_tdw8970
define Device/tplink_tdw8980
+ $(Device/dsa-migration)
$(Device/lantiqTpLink)
DEVICE_MODEL := TD-W8980
DEVICE_VARIANT := v1
@@ -39,6 +46,7 @@ endef
TARGET_DEVICES += tplink_tdw8980
define Device/tplink_vr200
+ $(Device/dsa-migration)
$(Device/lantiqTpLink)
DEVICE_MODEL := Archer VR200
DEVICE_VARIANT := v1
@@ -52,6 +60,7 @@ endef
TARGET_DEVICES += tplink_vr200
define Device/tplink_vr200v
+ $(Device/dsa-migration)
$(Device/lantiqTpLink)
DEVICE_MODEL := Archer VR200v
DEVICE_VARIANT := v1