aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/config-5.43
-rw-r--r--target/linux/kirkwood/image/Makefile3
2 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/kirkwood/config-5.4 b/target/linux/kirkwood/config-5.4
index 4be83a5139..da03efa94c 100644
--- a/target/linux/kirkwood/config-5.4
+++ b/target/linux/kirkwood/config-5.4
@@ -221,9 +221,6 @@ CONFIG_MDIO_BUS=y
CONFIG_MDIO_DEVICE=y
CONFIG_MEMFD_CREATE=y
CONFIG_MIGRATION=y
-CONFIG_MMC=y
-CONFIG_MMC_BLOCK=y
-CONFIG_MMC_MVSDIO=y
# CONFIG_MMC_TIFM_SD is not set
CONFIG_MODULES_USE_ELF_REL=y
# CONFIG_MTD_CFI is not set
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 76dfc4ea09..85bf0118ac 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -36,6 +36,7 @@ define Device/cisco_on100
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
BOARD_NAME := on100
+ DEVICE_PACKAGES := kmod-mvsdio
endef
TARGET_DEVICES += cisco_on100
@@ -50,7 +51,7 @@ define Device/cloudengines_pogoplugv4
DEVICE_VENDOR := Cloud Engines
DEVICE_MODEL := Pogoplug V4
DEVICE_DTS := kirkwood-pogoplug-series-4
- DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-mvsdio kmod-usb3
endef
TARGET_DEVICES += cloudengines_pogoplugv4