aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/generic
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx/generic')
-rw-r--r--target/linux/ixp4xx/generic/profiles/100-Default.mk17
-rw-r--r--target/linux/ixp4xx/generic/profiles/105-Atheros-ath5k.mk17
-rw-r--r--target/linux/ixp4xx/generic/profiles/200-NSLU2.mk19
-rw-r--r--target/linux/ixp4xx/generic/profiles/300-NAS100d.mk21
-rw-r--r--target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk22
-rw-r--r--target/linux/ixp4xx/generic/profiles/500-USR8200.mk19
-rw-r--r--target/linux/ixp4xx/generic/target.mk9
7 files changed, 0 insertions, 124 deletions
diff --git a/target/linux/ixp4xx/generic/profiles/100-Default.mk b/target/linux/ixp4xx/generic/profiles/100-Default.mk
deleted file mode 100644
index c881c8001d..0000000000
--- a/target/linux/ixp4xx/generic/profiles/100-Default.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
- NAME:=Default Profile
- PACKAGES:=kmod-ath5k
-endef
-
-define Profile/Default/Description
- Default IXP4xx Profile
-endef
-$(eval $(call Profile,Default))
-
diff --git a/target/linux/ixp4xx/generic/profiles/105-Atheros-ath5k.mk b/target/linux/ixp4xx/generic/profiles/105-Atheros-ath5k.mk
deleted file mode 100644
index 8f74277c3b..0000000000
--- a/target/linux/ixp4xx/generic/profiles/105-Atheros-ath5k.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Atheros-ath5k
- NAME:=Atheros WiFi (atk5k)
- PACKAGES:=kmod-ath5k
-endef
-
-define Profile/Atheros-ath5k/Description
- Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros-ath5k))
-
diff --git a/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk b/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
deleted file mode 100644
index 55073602a0..0000000000
--- a/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2006-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/NSLU2
- NAME:=Linksys NSLU2
- PACKAGES:=-wpad-basic -kmod-ath5k kmod-scsi-core \
- kmod-usb-ohci-pci kmod-usb2-pci kmod-usb-storage \
- kmod-fs-ext4
-endef
-
-define Profile/NSLU2/Description
- Package set optimized for the Linksys NSLU2
-endef
-$(eval $(call Profile,NSLU2))
-
diff --git a/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk b/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk
deleted file mode 100644
index a50eec09e0..0000000000
--- a/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk
+++ /dev/null
@@ -1,21 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/NAS100d
- NAME:=Iomega NAS 100d
- PACKAGES:=kmod-ath5k \
- kmod-scsi-core \
- kmod-ata-core kmod-ata-artop \
- kmod-usb2-pci kmod-usb-storage \
- kmod-fs-ext4
-endef
-
-define Profile/NAS100d/Description
- Package set optimized for the Iomega NAS 100d
-endef
-$(eval $(call Profile,NAS100d))
-
diff --git a/target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk b/target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk
deleted file mode 100644
index fe2b1ccc64..0000000000
--- a/target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk
+++ /dev/null
@@ -1,22 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DSMG600RevA
- NAME:=DSM-G600 Rev A
- PACKAGES:=kmod-via-velocity \
- kmod-ath5k \
- kmod-scsi-core \
- kmod-ata-core kmod-ata-artop \
- kmod-usb-uhci kmod-usb2-pci kmod-usb-storage \
- kmod-fs-ext4
-endef
-
-define Profile/DSMG600RevA/Description
- Package set optimized for the DSM-G600 Rev A
-endef
-$(eval $(call Profile,DSMG600RevA))
-
diff --git a/target/linux/ixp4xx/generic/profiles/500-USR8200.mk b/target/linux/ixp4xx/generic/profiles/500-USR8200.mk
deleted file mode 100644
index a4c1f7f430..0000000000
--- a/target/linux/ixp4xx/generic/profiles/500-USR8200.mk
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2006-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/USR8200
- NAME:=USRobotics USR8200
- PACKAGES:=-wpad-basic kmod-scsi-core \
- kmod-usb-uhci kmod-usb2-pci kmod-usb-storage \
- kmod-fs-ext4 kmod-firewire kmod-firewire-ohci kmod-firewire-sbp2
-endef
-
-define Profile/USR8200/Description
- Package set optimized for the USRobotics USR8200
-endef
-$(eval $(call Profile,USR8200))
-
diff --git a/target/linux/ixp4xx/generic/target.mk b/target/linux/ixp4xx/generic/target.mk
deleted file mode 100644
index 4794755fdc..0000000000
--- a/target/linux/ixp4xx/generic/target.mk
+++ /dev/null
@@ -1,9 +0,0 @@
-BOARDNAME:=Generic
-
-DEFAULT_PACKAGES+= wpad-basic
-
-define Target/Description
- Build firmware images for ixp4xx based boards that boot from internal flash
- (e.g : Linksys NSLU2, ...)
-endef
-