aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq807x/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq807x/image/generic.mk')
-rw-r--r--target/linux/ipq807x/image/generic.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ipq807x/image/generic.mk b/target/linux/ipq807x/image/generic.mk
index ae0d6d2ad0..23260ed1e7 100644
--- a/target/linux/ipq807x/image/generic.mk
+++ b/target/linux/ipq807x/image/generic.mk
@@ -17,6 +17,20 @@ define Device/UbiFit
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
+define Device/edgecore_eap102
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_VENDOR := Edgecore
+ DEVICE_MODEL := EAP102
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_DTS_CONFIG := config@ac02
+ SOC := ipq8071
+ DEVICE_PACKAGES := ipq-wifi-edgecore_eap102
+ IMAGE/factory.ubi := append-ubi | qsdk-ipq-factory-nand
+endef
+TARGET_DEVICES += edgecore_eap102
+
define Device/edimax_cax1800
$(call Device/FitImage)
$(call Device/UbiFit)