aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq807x/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq807x/image/generic.mk')
-rw-r--r--target/linux/ipq807x/image/generic.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ipq807x/image/generic.mk b/target/linux/ipq807x/image/generic.mk
index 811a32e942..3145e1b53f 100644
--- a/target/linux/ipq807x/image/generic.mk
+++ b/target/linux/ipq807x/image/generic.mk
@@ -116,3 +116,18 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
endif
endef
TARGET_DEVICES += xiaomi_ax9000
+
+define Device/zyxel_nbg7815
+ $(call Device/FitImage)
+ DEVICE_VENDOR := ZYXEL
+ DEVICE_MODEL := NBG7815
+ DEVICE_DTS_CONFIG := config@nbg7815
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SOC := ipq8074
+ IMAGES += factory.bin sysupgrade.bin
+ IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k
+ IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | sysupgrade-tar rootfs=$$$$@ | append-metadata
+ DEVICE_PACKAGES := ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci e2fsprogs kmod-fs-ext4 losetup kmod-hwmon-tmp103
+endef
+TARGET_DEVICES += zyxel_nbg7815