aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/patches/0083-soc-Introduce-drivers-soc-place-holder-for-SOC-speci.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/patches/0083-soc-Introduce-drivers-soc-place-holder-for-SOC-speci.patch')
-rw-r--r--target/linux/ipq806x/patches/0083-soc-Introduce-drivers-soc-place-holder-for-SOC-speci.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/target/linux/ipq806x/patches/0083-soc-Introduce-drivers-soc-place-holder-for-SOC-speci.patch b/target/linux/ipq806x/patches/0083-soc-Introduce-drivers-soc-place-holder-for-SOC-speci.patch
new file mode 100644
index 0000000000..837ec9d0c5
--- /dev/null
+++ b/target/linux/ipq806x/patches/0083-soc-Introduce-drivers-soc-place-holder-for-SOC-speci.patch
@@ -0,0 +1,68 @@
+From 2dac9498966c79a6abb09764419ffd42a44c78cf Mon Sep 17 00:00:00 2001
+From: Santosh Shilimkar <santosh.shilimkar@ti.com>
+Date: Wed, 23 Apr 2014 19:46:17 -0400
+Subject: [PATCH 083/182] soc: Introduce drivers/soc place-holder for SOC
+ specific drivers
+
+Based on earlier thread "https://lkml.org/lkml/2013/10/7/662" and
+discussion at Kernel Summit'2013, it was agreed to create
+'driver/soc' for drivers which are quite SOC specific.
+
+Further discussion on the subject is in response to
+the earlier version of the patch is here:
+ http://lwn.net/Articles/588942/
+
+Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+Cc: Kumar Gala <galak@codeaurora.org>
+Cc: Paul Walmsley <paul@pwsan.com>
+Cc: Olof Johansson <olof@lixom.net>
+Cc: Arnd Bergmann <arnd@arndb.de>
+Signed-off-by: Sandeep Nair <sandeep_n@ti.com>
+Signed-off-by: Santosh Shilimkar <santosh.shilimkar@ti.com>
+Signed-off-by: Kumar Gala <galak@codeaurora.org>
+---
+ drivers/Kconfig | 2 ++
+ drivers/Makefile | 3 +++
+ drivers/soc/Kconfig | 3 +++
+ 3 files changed, 8 insertions(+)
+ create mode 100644 drivers/soc/Kconfig
+
+diff --git a/drivers/Kconfig b/drivers/Kconfig
+index e0a4ae6..a299cbd 100644
+--- a/drivers/Kconfig
++++ b/drivers/Kconfig
+@@ -132,6 +132,8 @@ source "drivers/staging/Kconfig"
+
+ source "drivers/platform/Kconfig"
+
++source "drivers/soc/Kconfig"
++
+ source "drivers/clk/Kconfig"
+
+ source "drivers/hwspinlock/Kconfig"
+diff --git a/drivers/Makefile b/drivers/Makefile
+index 3d6de8b..4c2bdc1 100644
+--- a/drivers/Makefile
++++ b/drivers/Makefile
+@@ -33,6 +33,9 @@ obj-y += amba/
+ # really early.
+ obj-$(CONFIG_DMADEVICES) += dma/
+
++# SOC specific infrastructure drivers.
++obj-y += soc/
++
+ obj-$(CONFIG_VIRTIO) += virtio/
+ obj-$(CONFIG_XEN) += xen/
+
+diff --git a/drivers/soc/Kconfig b/drivers/soc/Kconfig
+new file mode 100644
+index 0000000..339baa8
+--- /dev/null
++++ b/drivers/soc/Kconfig
+@@ -0,0 +1,3 @@
++menu "SOC (System On Chip) specific Drivers"
++
++endmenu
+--
+1.7.10.4
+