aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/image/Makefile')
-rw-r--r--target/linux/ipq40xx/image/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 51e8bcc7e3..127af99ce5 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -344,6 +344,18 @@ define Device/dlink_dap-2610
endef
TARGET_DEVICES += dlink_dap-2610
+define Device/edgecore_ecw5211
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_TITLE := Edgecore ECW5211
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+ DEVICE_DTS := qcom-ipq4018-ecw5211
+ DEVICE_PACKAGES := ipq-wifi-edgecore_ecw5211 kmod-tpm-i2c-atmel kmod-usb-acm uboot-envtools
+endef
+TARGET_DEVICES += edgecore_ecw5211
+
define Device/engenius_eap1300
$(call Device/FitImage)
DEVICE_VENDOR := EnGenius