aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq40xx/image/Makefile')
-rw-r--r--target/linux/ipq40xx/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 127af99ce5..0f03e1f429 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -356,6 +356,19 @@ define Device/edgecore_ecw5211
endef
TARGET_DEVICES += edgecore_ecw5211
+define Device/edgecore_oap100
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_TITLE := Edgecore OAP100
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ IMAGES := nand-sysupgrade.bin
+ DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
+ DEVICE_DTS := qcom-ipq4019-oap100
+ DEVICE_PACKAGES := ipq-wifi-edgecore_oap100 kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
+endef
+TARGET_DEVICES += edgecore_oap100
+
define Device/engenius_eap1300
$(call Device/FitImage)
DEVICE_VENDOR := EnGenius