aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx23/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/imx23/modules.mk')
-rw-r--r--target/linux/imx23/modules.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/imx23/modules.mk b/target/linux/imx23/modules.mk
index 119ddd7bd7..f999c31e85 100644
--- a/target/linux/imx23/modules.mk
+++ b/target/linux/imx23/modules.mk
@@ -115,3 +115,18 @@ define KernelPackage/iio-mxs-lradc/description
endef
$(eval $(call KernelPackage,iio-mxs-lradc))
+
+define KernelPackage/crypto-hw-dcp
+ TITLE:=i.MX23/28 DCP hardware crypto module
+ DEPENDS:=@TARGET_imx23
+ KCONFIG:=CONFIG_CRYPTO_DEV_DCP
+ FILES:=$(LINUX_DIR)/drivers/crypto/dcp.ko
+ AUTOLOAD:=$(call AutoLoad,90,dcp)
+ $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
+endef
+
+define KernelPackage/crypto-hw-dcp/description
+ Kernel support for the i.MX23/28 DCP crypto engine
+endef
+
+$(eval $(call KernelPackage,crypto-hw-dcp))