aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/pending-5.15
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/pending-5.15')
-rw-r--r--target/linux/generic/pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch4
-rw-r--r--target/linux/generic/pending-5.15/400-mtd-mtdsplit-support.patch26
-rw-r--r--target/linux/generic/pending-5.15/482-mtd-spi-nor-add-gd25q512.patch6
-rw-r--r--target/linux/generic/pending-5.15/484-mtd-spi-nor-add-esmt-f25l16pa.patch4
-rw-r--r--target/linux/generic/pending-5.15/485-mtd-spi-nor-add-xmc-xm25qh128c.patch6
-rw-r--r--target/linux/generic/pending-5.15/500-fs_cdrom_dependencies.patch10
-rw-r--r--target/linux/generic/pending-5.15/683-of_net-add-mac-address-to-of-tree.patch8
7 files changed, 11 insertions, 53 deletions
diff --git a/target/linux/generic/pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch b/target/linux/generic/pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch
index eefbe4b543..55388fb58a 100644
--- a/target/linux/generic/pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch
+++ b/target/linux/generic/pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch
@@ -9,8 +9,6 @@ Fix an issue with kernel headers that broke perf.
include/uapi/linux/swab.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/include/uapi/linux/swab.h b/include/uapi/linux/swab.h
-index 7272f85d6d6a..3736f2fe1541 100644
--- a/include/uapi/linux/swab.h
+++ b/include/uapi/linux/swab.h
@@ -3,7 +3,7 @@
@@ -22,5 +20,3 @@ index 7272f85d6d6a..3736f2fe1541 100644
#include <asm/bitsperlong.h>
#include <asm/swab.h>
---
-
diff --git a/target/linux/generic/pending-5.15/400-mtd-mtdsplit-support.patch b/target/linux/generic/pending-5.15/400-mtd-mtdsplit-support.patch
index 63df1d070d..8b34f4f467 100644
--- a/target/linux/generic/pending-5.15/400-mtd-mtdsplit-support.patch
+++ b/target/linux/generic/pending-5.15/400-mtd-mtdsplit-support.patch
@@ -11,8 +11,6 @@ Subject: [PATCH] mtd: mtdsplit support
include/linux/mtd/partitions.h | 7 ++
5 files changed, 197 insertions(+), 25 deletions(-)
-diff --git a/drivers/mtd/Kconfig b/drivers/mtd/Kconfig
-index 796a2eccbef0..f9ed93c4cf0f 100644
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
@@ -12,6 +12,25 @@ menuconfig MTD
@@ -41,11 +39,9 @@ index 796a2eccbef0..f9ed93c4cf0f 100644
config MTD_TESTS
tristate "MTD tests support (DANGEROUS)"
depends on m
-diff --git a/drivers/mtd/Makefile b/drivers/mtd/Makefile
-index 593d0593a038..b14b7fe0f597 100644
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -9,6 +9,8 @@ mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
+@@ -9,6 +9,8 @@ mtd-y := mtdcore.o mtdsuper.o mtdconc
obj-y += parsers/
@@ -54,8 +50,6 @@ index 593d0593a038..b14b7fe0f597 100644
# 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o
obj-$(CONFIG_MTD_BLOCK) += mtdblock.o
-diff --git a/drivers/mtd/mtdpart.c b/drivers/mtd/mtdpart.c
-index d442fa94c872..f1ed12aae1fe 100644
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
@@ -15,11 +15,13 @@
@@ -72,7 +66,7 @@ index d442fa94c872..f1ed12aae1fe 100644
/*
* MTD methods which simply translate the effective address and pass through
-@@ -236,6 +238,146 @@ static int mtd_add_partition_attrs(struct mtd_info *new)
+@@ -236,6 +238,146 @@ static int mtd_add_partition_attrs(struc
return ret;
}
@@ -219,7 +213,7 @@ index d442fa94c872..f1ed12aae1fe 100644
int mtd_add_partition(struct mtd_info *parent, const char *name,
long long offset, long long length)
{
-@@ -274,6 +416,7 @@ int mtd_add_partition(struct mtd_info *parent, const char *name,
+@@ -274,6 +416,7 @@ int mtd_add_partition(struct mtd_info *p
if (ret)
goto err_remove_part;
@@ -227,7 +221,7 @@ index d442fa94c872..f1ed12aae1fe 100644
mtd_add_partition_attrs(child);
return 0;
-@@ -422,6 +565,7 @@ int add_mtd_partitions(struct mtd_info *parent,
+@@ -422,6 +565,7 @@ int add_mtd_partitions(struct mtd_info *
goto err_del_partitions;
}
@@ -235,7 +229,7 @@ index d442fa94c872..f1ed12aae1fe 100644
mtd_add_partition_attrs(child);
/* Look for subpartitions */
-@@ -438,31 +582,6 @@ int add_mtd_partitions(struct mtd_info *parent,
+@@ -438,31 +582,6 @@ err_del_partitions:
return ret;
}
@@ -267,11 +261,9 @@ index d442fa94c872..f1ed12aae1fe 100644
/*
* Many partition parsers just expected the core to kfree() all their data in
* one chunk. Do that by default.
-diff --git a/include/linux/mtd/mtd.h b/include/linux/mtd/mtd.h
-index 8a2c60235ebb..b092bf6ff97d 100644
--- a/include/linux/mtd/mtd.h
+++ b/include/linux/mtd/mtd.h
-@@ -613,6 +613,24 @@ static inline void mtd_align_erase_req(struct mtd_info *mtd,
+@@ -613,6 +613,24 @@ static inline void mtd_align_erase_req(s
req->len += mtd->erasesize - mod;
}
@@ -296,7 +288,7 @@ index 8a2c60235ebb..b092bf6ff97d 100644
static inline uint32_t mtd_div_by_ws(uint64_t sz, struct mtd_info *mtd)
{
if (mtd->writesize_shift)
-@@ -685,6 +703,13 @@ extern void __put_mtd_device(struct mtd_info *mtd);
+@@ -685,6 +703,13 @@ extern void __put_mtd_device(struct mtd_
extern struct mtd_info *get_mtd_device_nm(const char *name);
extern void put_mtd_device(struct mtd_info *mtd);
@@ -310,8 +302,6 @@ index 8a2c60235ebb..b092bf6ff97d 100644
struct mtd_notifier {
void (*add)(struct mtd_info *mtd);
-diff --git a/include/linux/mtd/partitions.h b/include/linux/mtd/partitions.h
-index b74a539ec581..65ba0dbf961d 100644
--- a/include/linux/mtd/partitions.h
+++ b/include/linux/mtd/partitions.h
@@ -75,6 +75,12 @@ struct mtd_part_parser_data {
@@ -335,5 +325,3 @@ index b74a539ec581..65ba0dbf961d 100644
};
/* Container for passing around a set of parsed partitions */
---
-
diff --git a/target/linux/generic/pending-5.15/482-mtd-spi-nor-add-gd25q512.patch b/target/linux/generic/pending-5.15/482-mtd-spi-nor-add-gd25q512.patch
index 96848e103f..7c8b686277 100644
--- a/target/linux/generic/pending-5.15/482-mtd-spi-nor-add-gd25q512.patch
+++ b/target/linux/generic/pending-5.15/482-mtd-spi-nor-add-gd25q512.patch
@@ -7,11 +7,9 @@ Subject: [PATCH] spi-nor/gigadevic: add gd25q512
drivers/mtd/spi-nor/gigadevice.c | 3 +++
1 file changed, 3 insertions(+)
-diff --git a/drivers/mtd/spi-nor/gigadevice.c b/drivers/mtd/spi-nor/gigadevice.c
-index e52ed19d864f..d25292ec1eb9 100644
--- a/drivers/mtd/spi-nor/gigadevice.c
+++ b/drivers/mtd/spi-nor/gigadevice.c
-@@ -53,6 +53,9 @@ static const struct flash_info gigadevice_parts[] = {
+@@ -53,6 +53,9 @@ static const struct flash_info gigadevic
SPI_NOR_4B_OPCODES | SPI_NOR_HAS_LOCK |
SPI_NOR_HAS_TB | SPI_NOR_TB_SR_BIT6)
.fixups = &gd25q256_fixups },
@@ -21,5 +19,3 @@ index e52ed19d864f..d25292ec1eb9 100644
};
const struct spi_nor_manufacturer spi_nor_gigadevice = {
---
-
diff --git a/target/linux/generic/pending-5.15/484-mtd-spi-nor-add-esmt-f25l16pa.patch b/target/linux/generic/pending-5.15/484-mtd-spi-nor-add-esmt-f25l16pa.patch
index d5b7259351..ab402e622a 100644
--- a/target/linux/generic/pending-5.15/484-mtd-spi-nor-add-esmt-f25l16pa.patch
+++ b/target/linux/generic/pending-5.15/484-mtd-spi-nor-add-esmt-f25l16pa.patch
@@ -10,8 +10,6 @@ flash.
drivers/mtd/spi-nor/esmt.c | 2 ++
1 file changed, 2 insertions(+)
-diff --git a/drivers/mtd/spi-nor/esmt.c b/drivers/mtd/spi-nor/esmt.c
-index cfc9218c1053..d1750807f005 100644
--- a/drivers/mtd/spi-nor/esmt.c
+++ b/drivers/mtd/spi-nor/esmt.c
@@ -10,6 +10,8 @@
@@ -23,5 +21,3 @@ index cfc9218c1053..d1750807f005 100644
{ "f25l32pa", INFO(0x8c2016, 0, 64 * 1024, 64,
SECT_4K | SPI_NOR_HAS_LOCK | SPI_NOR_SWP_IS_VOLATILE) },
{ "f25l32qa", INFO(0x8c4116, 0, 64 * 1024, 64,
---
-
diff --git a/target/linux/generic/pending-5.15/485-mtd-spi-nor-add-xmc-xm25qh128c.patch b/target/linux/generic/pending-5.15/485-mtd-spi-nor-add-xmc-xm25qh128c.patch
index 2823464a60..68e373ea23 100644
--- a/target/linux/generic/pending-5.15/485-mtd-spi-nor-add-xmc-xm25qh128c.patch
+++ b/target/linux/generic/pending-5.15/485-mtd-spi-nor-add-xmc-xm25qh128c.patch
@@ -11,11 +11,9 @@ Datasheet available at https://www.xmcwh.com/uploads/435/XM25QH128C.pdf
drivers/mtd/spi-nor/xmc.c | 2 ++
1 file changed, 2 insertions(+)
-diff --git a/drivers/mtd/spi-nor/xmc.c b/drivers/mtd/spi-nor/xmc.c
-index 2c7773b68993..99ee43a654c4 100644
--- a/drivers/mtd/spi-nor/xmc.c
+++ b/drivers/mtd/spi-nor/xmc.c
-@@ -14,6 +14,8 @@ static const struct flash_info xmc_parts[] = {
+@@ -14,6 +14,8 @@ static const struct flash_info xmc_parts
SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
{ "XM25QH128A", INFO(0x207018, 0, 64 * 1024, 256,
SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
@@ -24,5 +22,3 @@ index 2c7773b68993..99ee43a654c4 100644
};
const struct spi_nor_manufacturer spi_nor_xmc = {
---
-
diff --git a/target/linux/generic/pending-5.15/500-fs_cdrom_dependencies.patch b/target/linux/generic/pending-5.15/500-fs_cdrom_dependencies.patch
index b46865fb55..2053c0fbe2 100644
--- a/target/linux/generic/pending-5.15/500-fs_cdrom_dependencies.patch
+++ b/target/linux/generic/pending-5.15/500-fs_cdrom_dependencies.patch
@@ -10,8 +10,6 @@ Subject: [PATCH] fs: add cdrom dependency
fs/udf/Kconfig | 1 +
4 files changed, 4 insertions(+)
-diff --git a/fs/hfs/Kconfig b/fs/hfs/Kconfig
-index 129926b5142d..e0d2c647aa07 100644
--- a/fs/hfs/Kconfig
+++ b/fs/hfs/Kconfig
@@ -2,6 +2,7 @@
@@ -22,8 +20,6 @@ index 129926b5142d..e0d2c647aa07 100644
select NLS
help
If you say Y here, you will be able to mount Macintosh-formatted
-diff --git a/fs/hfsplus/Kconfig b/fs/hfsplus/Kconfig
-index 7d4229aecec0..648d91d1881f 100644
--- a/fs/hfsplus/Kconfig
+++ b/fs/hfsplus/Kconfig
@@ -2,6 +2,7 @@
@@ -34,8 +30,6 @@ index 7d4229aecec0..648d91d1881f 100644
select NLS
select NLS_UTF8
help
-diff --git a/fs/isofs/Kconfig b/fs/isofs/Kconfig
-index 08ffd37b9bb8..f74680379207 100644
--- a/fs/isofs/Kconfig
+++ b/fs/isofs/Kconfig
@@ -1,6 +1,7 @@
@@ -46,8 +40,6 @@ index 08ffd37b9bb8..f74680379207 100644
help
This is the standard file system used on CD-ROMs. It was previously
known as "High Sierra File System" and is called "hsfs" on other
-diff --git a/fs/udf/Kconfig b/fs/udf/Kconfig
-index 26e1a49f3ba7..3f85a084d2b5 100644
--- a/fs/udf/Kconfig
+++ b/fs/udf/Kconfig
@@ -1,6 +1,7 @@
@@ -58,5 +50,3 @@ index 26e1a49f3ba7..3f85a084d2b5 100644
select CRC_ITU_T
select NLS
help
---
-
diff --git a/target/linux/generic/pending-5.15/683-of_net-add-mac-address-to-of-tree.patch b/target/linux/generic/pending-5.15/683-of_net-add-mac-address-to-of-tree.patch
index 742d58b708..f7ef06a14a 100644
--- a/target/linux/generic/pending-5.15/683-of_net-add-mac-address-to-of-tree.patch
+++ b/target/linux/generic/pending-5.15/683-of_net-add-mac-address-to-of-tree.patch
@@ -15,11 +15,9 @@ property. This way, the MAC address can be accessed using procfs.
net/core/of_net.c | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
-diff --git a/net/core/of_net.c b/net/core/of_net.c
-index 71c38b532f72..43b28c8ddff9 100644
--- a/net/core/of_net.c
+++ b/net/core/of_net.c
-@@ -95,6 +95,27 @@ static int of_get_mac_addr_nvmem(struct device_node *np, u8 *addr)
+@@ -95,6 +95,27 @@ static int of_get_mac_addr_nvmem(struct
return 0;
}
@@ -47,7 +45,7 @@ index 71c38b532f72..43b28c8ddff9 100644
/**
* of_get_mac_address()
* @np: Caller's Device Node
-@@ -175,6 +196,7 @@ int of_get_mac_address(struct device_node *np, u8 *addr)
+@@ -175,6 +196,7 @@ found:
addr[5] = (mac_val >> 0) & 0xff;
}
@@ -55,5 +53,3 @@ index 71c38b532f72..43b28c8ddff9 100644
return ret;
}
EXPORT_SYMBOL(of_get_mac_address);
---
-