aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.18')
-rw-r--r--target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch2
-rw-r--r--target/linux/generic/patches-3.18/201-extra_optimization.patch4
-rw-r--r--target/linux/generic/patches-3.18/550-ubifs-symlink-xattr-support.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch b/target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch
index c75af99c60..6c26a47c5f 100644
--- a/target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch
+++ b/target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch
@@ -44,7 +44,7 @@ Miklos
--- a/fs/overlayfs/copy_up.c
+++ b/fs/overlayfs/copy_up.c
-@@ -313,6 +313,9 @@ int ovl_copy_up_one(struct dentry *paren
+@@ -315,6 +315,9 @@ int ovl_copy_up_one(struct dentry *paren
struct cred *override_cred;
char *link = NULL;
diff --git a/target/linux/generic/patches-3.18/201-extra_optimization.patch b/target/linux/generic/patches-3.18/201-extra_optimization.patch
index 7ec93a47f4..2e2ed66161 100644
--- a/target/linux/generic/patches-3.18/201-extra_optimization.patch
+++ b/target/linux/generic/patches-3.18/201-extra_optimization.patch
@@ -1,7 +1,7 @@
--- a/Makefile
+++ b/Makefile
-@@ -612,9 +612,9 @@ include $(srctree)/arch/$(SRCARCH)/Makef
- KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks,)
+@@ -614,9 +614,9 @@ KBUILD_CFLAGS += $(call cc-option,-fno-P
+ KBUILD_AFLAGS += $(call cc-option,-fno-PIE)
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
-KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
diff --git a/target/linux/generic/patches-3.18/550-ubifs-symlink-xattr-support.patch b/target/linux/generic/patches-3.18/550-ubifs-symlink-xattr-support.patch
index 42ae9cb84a..6e08ca302e 100644
--- a/target/linux/generic/patches-3.18/550-ubifs-symlink-xattr-support.patch
+++ b/target/linux/generic/patches-3.18/550-ubifs-symlink-xattr-support.patch
@@ -39,7 +39,7 @@
--- a/fs/ubifs/xattr.c
+++ b/fs/ubifs/xattr.c
-@@ -209,12 +209,12 @@ static int change_xattr(struct ubifs_inf
+@@ -210,12 +210,12 @@ static int change_xattr(struct ubifs_inf
goto out_free;
}
inode->i_size = ui->ui_size = size;