aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/270-x86_objdump_command.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.14/270-x86_objdump_command.patch')
-rw-r--r--target/linux/generic/patches-3.14/270-x86_objdump_command.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/270-x86_objdump_command.patch b/target/linux/generic/patches-3.14/270-x86_objdump_command.patch
new file mode 100644
index 0000000000..15062691a8
--- /dev/null
+++ b/target/linux/generic/patches-3.14/270-x86_objdump_command.patch
@@ -0,0 +1,16 @@
+Use the cross toolchain objdump command instead of assuming that the host
+toolchain has it.
+
+Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+
+--- a/arch/x86/boot/compressed/Makefile
++++ b/arch/x86/boot/compressed/Makefile
+@@ -75,7 +75,7 @@ suffix-$(CONFIG_KERNEL_XZ) := xz
+ suffix-$(CONFIG_KERNEL_LZO) := lzo
+ suffix-$(CONFIG_KERNEL_LZ4) := lz4
+
+-RUN_SIZE = $(shell objdump -h vmlinux | \
++RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
+ perl $(srctree)/arch/x86/tools/calc_run_size.pl)
+ quiet_cmd_mkpiggy = MKPIGGY $@
+ cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )