aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-5.15/221-module_exports.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/hack-5.15/221-module_exports.patch')
-rw-r--r--target/linux/generic/hack-5.15/221-module_exports.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/generic/hack-5.15/221-module_exports.patch b/target/linux/generic/hack-5.15/221-module_exports.patch
index cd38125f28..65cee1a541 100644
--- a/target/linux/generic/hack-5.15/221-module_exports.patch
+++ b/target/linux/generic/hack-5.15/221-module_exports.patch
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
/* Align . to a 8 byte boundary equals to maximum function alignment. */
#define ALIGN_FUNCTION() . = ALIGN(8)
-@@ -473,14 +483,14 @@
+@@ -484,14 +494,14 @@
/* Kernel symbol table: Normal symbols */ \
__ksymtab : AT(ADDR(__ksymtab) - LOAD_OFFSET) { \
__start___ksymtab = .; \
@@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
__stop___ksymtab_gpl = .; \
} \
\
-@@ -542,7 +552,7 @@
+@@ -511,7 +521,7 @@
\
/* Kernel symbol table: strings */ \
__ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) { \
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
} \
\
/* __*init sections */ \
-@@ -1019,6 +1029,8 @@
+@@ -1018,6 +1028,8 @@
#define COMMON_DISCARDS \
SANITIZER_DISCARDS \
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
"__kstrtabns_" #sym ": \n" \
--- a/scripts/Makefile.build
+++ b/scripts/Makefile.build
-@@ -367,7 +367,7 @@ targets += $(lib-y) $(always-y) $(MAKECM
+@@ -385,7 +385,7 @@ targets += $(real-dtb-y) $(lib-y) $(alwa
# Linker scripts preprocessor (.lds.S -> .lds)
# ---------------------------------------------------------------------------
quiet_cmd_cpp_lds_S = LDS $@