aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch
deleted file mode 100644
index 6077906ae3..0000000000
--- a/target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/drivers/input/misc/Kconfig
-+++ b/drivers/input/misc/Kconfig
-@@ -227,4 +227,20 @@ config INPUT_PCF50633_PMU
- Say Y to include support for delivering PMU events via input
- layer on NXP PCF50633.
-
-+config INPUT_GPIO_BUTTONS
-+ tristate "Polled GPIO buttons interface"
-+ depends on GENERIC_GPIO
-+ select INPUT_POLLDEV
-+ help
-+ This driver implements support for buttons connected
-+ to GPIO pins of various CPUs (and some other chips).
-+
-+ Say Y here if your device has buttons connected
-+ directly to such GPIO pins. Your board-specific
-+ setup logic must also provide a platform device,
-+ with configuration data saying which GPIOs are used.
-+
-+ To compile this driver as a module, choose M here: the
-+ module will be called gpio-buttons.
-+
- endif
---- a/drivers/input/misc/Makefile
-+++ b/drivers/input/misc/Makefile
-@@ -22,3 +22,4 @@ obj-$(CONFIG_INPUT_UINPUT) += uinput.o
- obj-$(CONFIG_INPUT_APANEL) += apanel.o
- obj-$(CONFIG_INPUT_SGI_BTNS) += sgi_btns.o
- obj-$(CONFIG_INPUT_PCF50633_PMU) += pcf50633-input.o
-+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o