aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/modules.mk')
-rw-r--r--target/linux/generic-2.6/modules.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/generic-2.6/modules.mk b/target/linux/generic-2.6/modules.mk
index ab8a5f5d51..b582400bd6 100644
--- a/target/linux/generic-2.6/modules.mk
+++ b/target/linux/generic-2.6/modules.mk
@@ -14,10 +14,14 @@ $(eval $(call KMOD_template,GRE,gre,\
,CONFIG_NET_IPGRE))
$(eval $(call KMOD_template,IMQ,imq,\
- $(MODULES_DIR)/kernel/net/*/netfilter/*IMQ*.ko \
+ $(MODULES_DIR)/kernel/net/ipv4/netfilter/*IMQ*.ko \
$(MODULES_DIR)/kernel/drivers/net/imq.ko \
))
+$(eval $(call KMOD_template,IPIP,ipip,\
+ $(MODULES_DIR)/kernel/net/ipv4/ipip.ko \
+,CONFIG_NET_IPIP,,60,ipip))
+
$(eval $(call KMOD_template,IPV6,ipv6,\
$(MODULES_DIR)/kernel/net/ipv6/ipv6.ko \
,CONFIG_IPV6,,20,ipv6))