aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/620-netfilter_iprange.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.4/patches/620-netfilter_iprange.patch')
-rw-r--r--target/linux/generic-2.4/patches/620-netfilter_iprange.patch26
1 files changed, 8 insertions, 18 deletions
diff --git a/target/linux/generic-2.4/patches/620-netfilter_iprange.patch b/target/linux/generic-2.4/patches/620-netfilter_iprange.patch
index ed1927fb51..505d22ee1a 100644
--- a/target/linux/generic-2.4/patches/620-netfilter_iprange.patch
+++ b/target/linux/generic-2.4/patches/620-netfilter_iprange.patch
@@ -1,7 +1,5 @@
-Index: linux-2.4.35.4/Documentation/Configure.help
-===================================================================
---- linux-2.4.35.4.orig/Documentation/Configure.help
-+++ linux-2.4.35.4/Documentation/Configure.help
+--- a/Documentation/Configure.help
++++ b/Documentation/Configure.help
@@ -2986,6 +2986,14 @@ CONFIG_IP_NF_MATCH_TOS
If you want to compile it as a module, say M here and read
<file:Documentation/modules.txt>. If unsure, say `N'.
@@ -17,10 +15,8 @@ Index: linux-2.4.35.4/Documentation/Configure.help
Condition variable match support
CONFIG_IP_NF_MATCH_CONDITION
This option allows you to match firewall rules against condition
-Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_iprange.h
-===================================================================
--- /dev/null
-+++ linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_iprange.h
++++ b/include/linux/netfilter_ipv4/ipt_iprange.h
@@ -0,0 +1,23 @@
+#ifndef _IPT_IPRANGE_H
+#define _IPT_IPRANGE_H
@@ -45,10 +41,8 @@ Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_iprange.h
+};
+
+#endif /* _IPT_IPRANGE_H */
-Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
-===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Config.in
-+++ linux-2.4.35.4/net/ipv4/netfilter/Config.in
+--- a/net/ipv4/netfilter/Config.in
++++ b/net/ipv4/netfilter/Config.in
@@ -27,6 +27,7 @@ tristate 'IP tables support (required fo
if [ "$CONFIG_IP_NF_IPTABLES" != "n" ]; then
# The simple matches.
@@ -57,10 +51,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
dep_tristate ' quota match support' CONFIG_IP_NF_MATCH_QUOTA $CONFIG_IP_NF_IPTABLES
dep_tristate ' IP set support' CONFIG_IP_NF_SET $CONFIG_IP_NF_IPTABLES
-Index: linux-2.4.35.4/net/ipv4/netfilter/ipt_iprange.c
-===================================================================
--- /dev/null
-+++ linux-2.4.35.4/net/ipv4/netfilter/ipt_iprange.c
++++ b/net/ipv4/netfilter/ipt_iprange.c
@@ -0,0 +1,101 @@
+/*
+ * iptables module to match IP address ranges
@@ -163,10 +155,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ipt_iprange.c
+
+module_init(init);
+module_exit(fini);
-Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.4.35.4/net/ipv4/netfilter/Makefile
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
@@ -90,6 +90,7 @@ obj-$(CONFIG_IP_NF_NAT) += iptable_nat.o
# matches
obj-$(CONFIG_IP_NF_MATCH_HELPER) += ipt_helper.o