aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image/bcm63xx.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm63xx/image/bcm63xx.mk')
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 04cbf124a7..dd1ad86501 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -1,3 +1,4 @@
+
#
# BCM33XX/BCM63XX Profiles
#
@@ -174,6 +175,21 @@ define Device/96368MVWG-generic
endef
TARGET_DEVICES += 96368MVWG-generic
+### Actiontec ###
+define Device/R1000H
+ $(Device/bcm63xx)
+ FILESYSTEMS := squashfs
+ DEVICE_TITLE := Actiontec R1000H
+ DEVICE_DTS := r1000h
+ CFE_BOARD_ID := 96368MVWG
+ CFE_CHIP_ID := 6368
+ FLASH_MB := 32
+ IMAGE_OFFSET := 0x20000
+ DEVICE_PACKAGES := \
+ $(USB2_PACKAGES) $(BRCMWL_PACKAGES)
+endef
+TARGET_DEVICES += R1000H
+
### ADB ###
define Device/A4001N
$(Device/bcm63xx)