aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/patches-5.15/600-mips-bmips-add-pci-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bmips/patches-5.15/600-mips-bmips-add-pci-support.patch')
-rw-r--r--target/linux/bmips/patches-5.15/600-mips-bmips-add-pci-support.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/bmips/patches-5.15/600-mips-bmips-add-pci-support.patch b/target/linux/bmips/patches-5.15/600-mips-bmips-add-pci-support.patch
new file mode 100644
index 0000000000..b219868442
--- /dev/null
+++ b/target/linux/bmips/patches-5.15/600-mips-bmips-add-pci-support.patch
@@ -0,0 +1,20 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -276,6 +276,7 @@ config BMIPS_GENERIC
+ select BCM7038_L1_IRQ
+ select BCM7120_L2_IRQ
+ select BRCMSTB_L2_IRQ
++ select HAVE_PCI
+ select IRQ_MIPS_CPU
+ select DMA_NONCOHERENT
+ select SYS_SUPPORTS_32BIT_KERNEL
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_PCI_XTALK_BRIDGE) += pci-xt
+ # These are still pretty much in the old state, watch, go blind.
+ #
+ obj-$(CONFIG_ATH79) += fixup-ath79.o
++obj-$(CONFIG_BMIPS_GENERIC) += fixup-bmips.o
+ obj-$(CONFIG_MIPS_COBALT) += fixup-cobalt.o
+ obj-$(CONFIG_LEMOTE_FULOONG2E) += fixup-fuloong2e.o ops-loongson2.o
+ obj-$(CONFIG_LEMOTE_MACH2F) += fixup-lemote2f.o ops-loongson2.o