aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm63xx_nand.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bmips/image/bcm63xx_nand.mk')
-rw-r--r--target/linux/bmips/image/bcm63xx_nand.mk54
1 files changed, 54 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm63xx_nand.mk b/target/linux/bmips/image/bcm63xx_nand.mk
index 6c4655bbab..01540625ed 100644
--- a/target/linux/bmips/image/bcm63xx_nand.mk
+++ b/target/linux/bmips/image/bcm63xx_nand.mk
@@ -100,3 +100,57 @@ define Device/netgear_dgnd3700-v2
CFE_WFI_VERSION := 0x5731
endef
TARGET_DEVICES += netgear_dgnd3700-v2
+
+define Device/sercomm_h500-s-lowi
+ $(Device/sercomm-nand)
+ DEVICE_VENDOR := Sercomm
+ DEVICE_MODEL := H500-s
+ DEVICE_VARIANT := lowi
+ DEVICE_LOADADDR := $(KERNEL_LOADADDR)
+ KERNEL := kernel-bin | append-dtb | lzma | cfe-jffs2-kernel
+ CHIP_ID := 63268
+ SOC := bcm63167
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES)
+ SERCOMM_PID := \
+ 30 30 30 30 30 30 30 31 34 33 34 62 33 31 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 33 33 30 35 30 30 30 30 30 30 30 30 \
+ 0D 0A 00 00 00 00 00 00 00 00 00 00 00 00 00 00
+ SERCOMM_VERSION := 1001
+endef
+TARGET_DEVICES += sercomm_h500-s-lowi
+
+define Device/sercomm_h500-s-vfes
+ $(Device/sercomm-nand)
+ DEVICE_VENDOR := Sercomm
+ DEVICE_MODEL := H500-s
+ DEVICE_VARIANT := vfes
+ DEVICE_LOADADDR := $(KERNEL_LOADADDR)
+ KERNEL := kernel-bin | append-dtb | lzma | cfe-jffs2-kernel
+ CHIP_ID := 63268
+ SOC := bcm63167
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES)
+ SERCOMM_PID := \
+ 30 30 30 30 30 30 30 31 34 32 35 38 34 62 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 33 34 31 37 30 30 30 30 30 30 30 30 \
+ 0D 0A 00 00 00 00 00 00 00 00 00 00 00 00 00 00
+ SERCOMM_VERSION := 1001
+endef
+TARGET_DEVICES += sercomm_h500-s-vfes