aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm6368.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bmips/image/bcm6368.mk')
-rw-r--r--target/linux/bmips/image/bcm6368.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm6368.mk b/target/linux/bmips/image/bcm6368.mk
index 83cd096959..39fcb02318 100644
--- a/target/linux/bmips/image/bcm6368.mk
+++ b/target/linux/bmips/image/bcm6368.mk
@@ -1,5 +1,20 @@
# SPDX-License-Identifier: GPL-2.0-or-later
+define Device/actiontec_r1000h
+ $(Device/bcm63xx-cfe)
+ DEVICE_VENDOR := Actiontec
+ DEVICE_MODEL := R1000H
+ CHIP_ID := 6368
+ CFE_BOARD_ID := 96368VVW
+ BLOCKSIZE := 0x20000
+ FLASH_MB := 32
+ CFE_EXTRAS += --signature "$$(DEVICE_VENDOR)"
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) \
+ kmod-leds-gpio
+endef
+TARGET_DEVICES += actiontec_r1000h
+
define Device/comtrend_vr-3025u
$(Device/bcm63xx-cfe)
DEVICE_VENDOR := Comtrend