aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/image/bcm63xx_nand.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm63xx/image/bcm63xx_nand.mk')
-rw-r--r--target/linux/bcm63xx/image/bcm63xx_nand.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/bcm63xx/image/bcm63xx_nand.mk b/target/linux/bcm63xx/image/bcm63xx_nand.mk
index 8e733f2b23..5be27a3f75 100644
--- a/target/linux/bcm63xx/image/bcm63xx_nand.mk
+++ b/target/linux/bcm63xx/image/bcm63xx_nand.mk
@@ -33,3 +33,21 @@ define Device/bcm63xx-nand
DEVICE_PACKAGES += nand-utils
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
endef
+
+### Comtrend ###
+define Device/comtrend_vr-3032u
+ $(Device/bcm63xx-nand)
+ DEVICE_VENDOR := Comtrend
+ DEVICE_MODEL := VR-3032u
+ CFE_CHIP_ID := 63268
+ SOC := bcm63168
+ CFE_RAM_FILE := comtrend,vr-3032u/cferam.000
+ CFE_RAM_JFFS2_NAME := cferam.000
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES)
+ CFE_WFI_FLASH_TYPE := 3
+endef
+TARGET_DEVICES += comtrend_vr-3032u