aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/image/bcm63xx.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm63xx/image/bcm63xx.mk')
-rw-r--r--target/linux/bcm63xx/image/bcm63xx.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/bcm63xx/image/bcm63xx.mk b/target/linux/bcm63xx/image/bcm63xx.mk
index 81cf98b44b..773f098dea 100644
--- a/target/linux/bcm63xx/image/bcm63xx.mk
+++ b/target/linux/bcm63xx/image/bcm63xx.mk
@@ -1099,6 +1099,18 @@ endef
TARGET_DEVICES += t-com_speedport-w-500v
### Technicolor ###
+define Device/technicolor_tg582n
+ $(Device/bcm63xx)
+ DEVICE_VENDOR := Technicolor
+ DEVICE_MODEL := TG582n
+ IMAGES += sysupgrade.bin
+ CFE_BOARD_ID := DANT-1
+ CHIP_ID := 6328
+ FLASH_MB := 16
+ DEVICE_PACKAGES := $(USB2_PACKAGES) $(B43_PACKAGES)
+endef
+TARGET_DEVICES += technicolor_tg582n
+
define Device/technicolor_tg582n-telecom-italia
$(Device/bcm63xx)
DEVICE_VENDOR := Technicolor