aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/patches-5.10/036-v5.19-0008-ARM-dts-BCM5301X-Add-DT-for-WZR-1166DHP-DHP2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx/patches-5.10/036-v5.19-0008-ARM-dts-BCM5301X-Add-DT-for-WZR-1166DHP-DHP2.patch')
-rw-r--r--target/linux/bcm53xx/patches-5.10/036-v5.19-0008-ARM-dts-BCM5301X-Add-DT-for-WZR-1166DHP-DHP2.patch300
1 files changed, 300 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/patches-5.10/036-v5.19-0008-ARM-dts-BCM5301X-Add-DT-for-WZR-1166DHP-DHP2.patch b/target/linux/bcm53xx/patches-5.10/036-v5.19-0008-ARM-dts-BCM5301X-Add-DT-for-WZR-1166DHP-DHP2.patch
new file mode 100644
index 0000000000..bce497bba7
--- /dev/null
+++ b/target/linux/bcm53xx/patches-5.10/036-v5.19-0008-ARM-dts-BCM5301X-Add-DT-for-WZR-1166DHP-DHP2.patch
@@ -0,0 +1,300 @@
+From 417aea4436bb658d8c5c4dcd0e3c255931d0ee96 Mon Sep 17 00:00:00 2001
+From: SHIMAMOTO Takayoshi <takayoshi.shimamoto.360@gmail.com>
+Date: Fri, 22 Apr 2022 00:10:54 +0900
+Subject: [PATCH] ARM: dts: BCM5301X: Add DT for WZR-1166DHP,DHP2
+
+Buffalo WZR-1166DHP/WZR-1166DHP2 wireless router with
+
+ - BCM4708A0
+ - 128MiB NAND flash
+ - 2T2R 11ac/a/b/g/n Wi-Fi
+ - 4x 10/100/1000M ethernet switch
+ - 1x USB 3.0 port
+
+ WZR-1166DHP and WZR-1166DHP2 have different memory capacity.
+
+ WZR-1166DHP
+ - 512 MiB DDR2 SDRAM
+
+ WZR-1166DHP2
+ - 256 MiB DDR2 SDRAM
+
+ These hardware components are very similar to the WZR-1750DHP
+ except for the number of antennas.
+
+Signed-off-by: SHIMAMOTO Takayoshi <takayoshi.shimamoto.360@gmail.com>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile | 2 +
+ .../bcm4708-buffalo-wzr-1166dhp-common.dtsi | 192 ++++++++++++++++++
+ .../boot/dts/bcm4708-buffalo-wzr-1166dhp.dts | 26 +++
+ .../boot/dts/bcm4708-buffalo-wzr-1166dhp2.dts | 26 +++
+ 4 files changed, 246 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm4708-buffalo-wzr-1166dhp-common.dtsi
+ create mode 100644 arch/arm/boot/dts/bcm4708-buffalo-wzr-1166dhp.dts
+ create mode 100644 arch/arm/boot/dts/bcm4708-buffalo-wzr-1166dhp2.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -99,6 +99,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+ bcm4708-asus-rt-ac56u.dtb \
+ bcm4708-asus-rt-ac68u.dtb \
+ bcm4708-buffalo-wzr-1750dhp.dtb \
++ bcm4708-buffalo-wzr-1166dhp.dtb \
++ bcm4708-buffalo-wzr-1166dhp2.dtb \
+ bcm4708-linksys-ea6300-v1.dtb \
+ bcm4708-linksys-ea6500-v2.dtb \
+ bcm4708-luxul-xap-1510.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1166dhp-common.dtsi
+@@ -0,0 +1,192 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Broadcom BCM470X / BCM5301X ARM platform code.
++ * DTS for Buffalo WZR-1166DHP and WZR-1166DHP2
++ *
++ * Copyright (C) 2014 Rafał Miłecki <zajec5@gmail.com>
++ * Copyright (C) 2022 SHIMAMOTO Takayoshi <takayoshi.shimamoto.360@gmail.com>
++ */
++
++
++#include "bcm4708.dtsi"
++#include "bcm5301x-nand-cs0-bch8.dtsi"
++#include <dt-bindings/leds/common.h>
++
++/ {
++ spi {
++ compatible = "spi-gpio";
++ num-chipselects = <1>;
++ gpio-sck = <&chipcommon 7 0>;
++ gpio-mosi = <&chipcommon 4 0>;
++ cs-gpios = <&chipcommon 6 0>;
++ #address-cells = <1>;
++ #size-cells = <0>;
++
++ hc595: gpio_spi@0 {
++ compatible = "fairchild,74hc595";
++ reg = <0>;
++ registers-number = <1>;
++ spi-max-frequency = <100000>;
++
++ gpio-controller;
++ #gpio-cells = <2>;
++
++ };
++ };
++
++ leds {
++ compatible = "gpio-leds";
++
++ usb {
++ /* label = "bcm53xx:blue:usb"; */
++ function = LED_FUNCTION_USB;
++ color = <LED_COLOR_ID_BLUE>;
++ gpios = <&hc595 0 GPIO_ACTIVE_HIGH>;
++ trigger-sources = <&ohci_port1>, <&ehci_port1>,
++ <&xhci_port1>, <&ohci_port2>,
++ <&ehci_port2>;
++ linux,default-trigger = "usbport";
++ };
++
++ power0 {
++ /* label = "bcm53xx:red:power"; */
++ function = LED_FUNCTION_FAULT;
++ color = <LED_COLOR_ID_RED>;
++ gpios = <&hc595 1 GPIO_ACTIVE_HIGH>;
++ };
++
++ power1 {
++ /* label = "bcm53xx:white:power"; */
++ function = LED_FUNCTION_POWER;
++ color = <LED_COLOR_ID_WHITE>;
++ gpios = <&hc595 2 GPIO_ACTIVE_HIGH>;
++ linux,default-trigger = "default-on";
++ };
++
++ router0 {
++ /* label = "bcm53xx:blue:router"; */
++ function = LED_FUNCTION_STATUS;
++ color = <LED_COLOR_ID_BLUE>;
++ gpios = <&hc595 3 GPIO_ACTIVE_HIGH>;
++ linux,default-trigger = "default-on";
++ };
++
++ router1 {
++ /* label = "bcm53xx:amber:router"; */
++ function = LED_FUNCTION_STATUS;
++ color = <LED_COLOR_ID_AMBER>;
++ gpios = <&hc595 4 GPIO_ACTIVE_HIGH>;
++ };
++
++ wan {
++ /* label = "bcm53xx:blue:wan"; */
++ function = LED_FUNCTION_WAN;
++ color = <LED_COLOR_ID_BLUE>;
++ gpios = <&hc595 5 GPIO_ACTIVE_HIGH>;
++ linux,default-trigger = "default-on";
++ };
++
++ wireless0 {
++ /* label = "bcm53xx:blue:wireless"; */
++ function = LED_FUNCTION_WLAN;
++ color = <LED_COLOR_ID_BLUE>;
++ gpios = <&hc595 6 GPIO_ACTIVE_HIGH>;
++ };
++
++ wireless1 {
++ /* label = "bcm53xx:amber:wireless"; */
++ function = LED_FUNCTION_WLAN;
++ color = <LED_COLOR_ID_AMBER>;
++ gpios = <&hc595 7 GPIO_ACTIVE_HIGH>;
++ };
++ };
++
++ gpio-keys {
++ compatible = "gpio-keys";
++
++ restart {
++ label = "Reset";
++ linux,code = <KEY_RESTART>;
++ gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
++ };
++
++ aoss {
++ label = "AOSS";
++ linux,code = <KEY_WPS_BUTTON>;
++ gpios = <&chipcommon 12 GPIO_ACTIVE_LOW>;
++ };
++
++ /* Commit mode set by switch? */
++ mode {
++ label = "Mode";
++ linux,code = <KEY_SETUP>;
++ gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
++ };
++
++ /* Switch: AP mode */
++ sw_ap {
++ label = "AP";
++ linux,code = <BTN_0>;
++ gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
++ };
++
++ eject {
++ label = "USB eject";
++ linux,code = <KEY_EJECTCD>;
++ gpios = <&chipcommon 15 GPIO_ACTIVE_LOW>;
++ };
++ };
++};
++
++&usb2 {
++ vcc-gpio = <&chipcommon 9 GPIO_ACTIVE_HIGH>;
++};
++
++&usb3 {
++ vcc-gpio = <&chipcommon 10 GPIO_ACTIVE_LOW>;
++};
++
++&spi_nor {
++ status = "okay";
++};
++
++&usb3_phy {
++ status = "okay";
++};
++
++&srab {
++ status = "okay";
++
++ ports {
++ port@0 {
++ reg = <0>;
++ label = "lan1";
++ };
++
++ port@1 {
++ reg = <1>;
++ label = "lan2";
++ };
++
++ port@2 {
++ reg = <2>;
++ label = "lan3";
++ };
++
++ port@3 {
++ reg = <3>;
++ label = "lan4";
++ };
++
++ port@4 {
++ reg = <4>;
++ label = "wan";
++ };
++
++ port@5 {
++ reg = <5>;
++ label = "cpu";
++ ethernet = <&gmac0>;
++ };
++ };
++};
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1166dhp.dts
+@@ -0,0 +1,26 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Device Tree Bindigs for Buffalo WZR-1166DHP
++ *
++ * Copyright (C) 2022 SHIMAMOTO Takayoshi <takayoshi.shimamoto.360@gmail.com>
++ */
++
++/dts-v1/;
++
++#include "bcm4708-buffalo-wzr-1166dhp-common.dtsi"
++
++/ {
++ compatible = "buffalo,wzr-1166dhp", "brcm,bcm4708";
++ model = "Buffalo WZR-1166DHP";
++
++ chosen {
++ bootargs = "console=ttyS0,115200";
++ };
++
++ memory@0 {
++ device_type = "memory";
++ reg = <0x00000000 0x08000000>,
++ <0x88000000 0x18000000>;
++ };
++
++};
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1166dhp2.dts
+@@ -0,0 +1,26 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Device Tree Bindigs for Buffalo WZR-1166DHP2
++ *
++ * Copyright (C) 2022 SHIMAMOTO Takayoshi <takayoshi.shimamoto.360@gmail.com>
++ */
++
++/dts-v1/;
++
++#include "bcm4708-buffalo-wzr-1166dhp-common.dtsi"
++
++/ {
++ compatible = "buffalo,wzr-1166dhp2", "brcm,bcm4708";
++ model = "Buffalo WZR-1166DHP2";
++
++ chosen {
++ bootargs = "console=ttyS0,115200";
++ };
++
++ memory@0 {
++ device_type = "memory";
++ reg = <0x00000000 0x08000000>,
++ <0x88000000 0x08000000>;
++ };
++
++};