aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.28/130-ar2313_ethernet.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/atheros/patches-2.6.28/130-ar2313_ethernet.patch')
-rw-r--r--target/linux/atheros/patches-2.6.28/130-ar2313_ethernet.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/atheros/patches-2.6.28/130-ar2313_ethernet.patch b/target/linux/atheros/patches-2.6.28/130-ar2313_ethernet.patch
new file mode 100644
index 0000000000..5c183a431f
--- /dev/null
+++ b/target/linux/atheros/patches-2.6.28/130-ar2313_ethernet.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -359,6 +359,12 @@ config AX88796_93CX6
+ help
+ Select this if your platform comes with an external 93CX6 eeprom.
+
++config AR2313
++ tristate "AR2313 Ethernet support"
++ depends on NET_ETHERNET && ATHEROS
++ help
++ Support for the AR231x/531x ethernet controller
++
+ config MACE
+ tristate "MACE (Power Mac ethernet) support"
+ depends on PPC_PMAC && PPC32
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -199,6 +199,7 @@ obj-$(CONFIG_EQUALIZER) += eql.o
+ obj-$(CONFIG_KORINA) += korina.o
+ obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
+ obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
++obj-$(CONFIG_AR2313) += ar2313/
+ obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
+ obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
+ obj-$(CONFIG_DECLANCE) += declance.o