aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/atheros/image/Makefile')
-rw-r--r--target/linux/atheros/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 40044895b8..15cd995865 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -51,6 +51,12 @@ define Image/Build
-p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
$(BIN_DIR)/openwrt-$(BOARD)-wpe53g-$(1).bin
+ ifeq ($(BOARD),atheros)
+ -sh $(TOPDIR)/scripts/combined-image.sh \
+ "$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" \
+ "$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" \
+ "$(BIN_DIR)/openwrt-$(BOARD)-combined.img"
+ endif
endef
$(eval $(call BuildImage))