aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch')
-rw-r--r--target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch b/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
index 1ebf87c610..59ee57d277 100644
--- a/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
+++ b/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
@@ -1,18 +1,18 @@
--- a/drivers/mtd/parsers/Makefile
+++ b/drivers/mtd/parsers/Makefile
-@@ -5,6 +5,7 @@ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm6
- obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
- obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myl
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ ofpart-y += ofpart_core.o
+ ofpart-$(CONFIG_MTD_OF_PARTS_BCM4908) += ofpart_bcm4908.o
+obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
obj-$(CONFIG_MTD_PARSER_IMAGETAG) += parser_imagetag.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
--- a/drivers/mtd/parsers/Kconfig
+++ b/drivers/mtd/parsers/Kconfig
-@@ -83,6 +83,14 @@ config MTD_OF_PARTS
- flash memory node, as described in
- Documentation/devicetree/bindings/mtd/partition.txt.
+@@ -92,6 +92,14 @@ config MTD_OF_PARTS_BCM4908
+ that can have multiple "firmware" partitions. It takes care of
+ finding currently used one and backup ones.
+config MTD_PARSER_CYBERTAN
+ tristate "Parser for Cybertan format partitions"