aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.19/404-mtd-cybertan-trx-parser.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/patches-4.19/404-mtd-cybertan-trx-parser.patch')
-rw-r--r--target/linux/ath79/patches-4.19/404-mtd-cybertan-trx-parser.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-4.19/404-mtd-cybertan-trx-parser.patch b/target/linux/ath79/patches-4.19/404-mtd-cybertan-trx-parser.patch
new file mode 100644
index 0000000000..22e31db3fa
--- /dev/null
+++ b/target/linux/ath79/patches-4.19/404-mtd-cybertan-trx-parser.patch
@@ -0,0 +1,20 @@
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -1,2 +1,3 @@
++obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
+ obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
+ obj-$(CONFIG_MTD_SHARPSL_PARTS) += sharpslpart.o
+--- a/drivers/mtd/parsers/Kconfig
++++ b/drivers/mtd/parsers/Kconfig
+@@ -1,3 +1,11 @@
++config MTD_PARSER_CYBERTAN
++ tristate "Parser for Cybertan format partitions"
++ depends on MTD && (ATH79 || COMPILE_TEST)
++ help
++ Cybertan has a proprietory header than encompasses a Broadcom trx
++ header. This driver will parse the header and take care of the
++ special offsets that result in the extra headers.
++
+ config MTD_PARSER_TRX
+ tristate "Parser for TRX format partitions"
+ depends on MTD && (BCM47XX || ARCH_BCM_5301X || COMPILE_TEST)