aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch')
-rw-r--r--target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch b/target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch
new file mode 100644
index 0000000000..3734d3e5c5
--- /dev/null
+++ b/target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch
@@ -0,0 +1,29 @@
+Index: linux-4.14.18/drivers/mtd/Kconfig
+===================================================================
+--- linux-4.14.18.orig/drivers/mtd/Kconfig
++++ linux-4.14.18/drivers/mtd/Kconfig
+@@ -194,6 +194,12 @@ config MTD_MYLOADER_PARTS
+ You will still need the parsing functions to be called by the driver
+ for your particular device. It won't happen automatically.
+
++config MTD_TPLINK_PARTS
++ tristate "TP-Link AR7XXX/AR9XXX partitioning support"
++ depends on ATH79
++ ---help---
++ TBD.
++
+ comment "User Modules And Translation Layers"
+
+ #
+Index: linux-4.14.18/drivers/mtd/Makefile
+===================================================================
+--- linux-4.14.18.orig/drivers/mtd/Makefile
++++ linux-4.14.18/drivers/mtd/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+ obj-y += parsers/
++obj-$(CONFIG_MTD_TPLINK_PARTS) += tplinkpart.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o