aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/nand
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/nand')
-rw-r--r--target/linux/ath79/nand/config-default14
-rw-r--r--target/linux/ath79/nand/profiles/00-default.mk18
-rw-r--r--target/linux/ath79/nand/target.mk7
3 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ath79/nand/config-default b/target/linux/ath79/nand/config-default
new file mode 100644
index 0000000000..738c29c9b1
--- /dev/null
+++ b/target/linux/ath79/nand/config-default
@@ -0,0 +1,14 @@
+CONFIG_BCH=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_BCH=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_ECC_BCH=y
+CONFIG_MTD_SPINAND_MT29F=y
+CONFIG_MTD_SPINAND_ONDIEECC=y
+CONFIG_MTD_UBI=y
+CONFIG_MTD_UBI_BEB_LIMIT=20
+# CONFIG_MTD_UBI_BLOCK is not set
+# CONFIG_MTD_UBI_FASTMAP is not set
+# CONFIG_MTD_UBI_GLUEBI is not set
+CONFIG_MTD_UBI_WL_THRESHOLD=4096
+# CONFIG_UBIFS_FS is not set
diff --git a/target/linux/ath79/nand/profiles/00-default.mk b/target/linux/ath79/nand/profiles/00-default.mk
new file mode 100644
index 0000000000..06ab790389
--- /dev/null
+++ b/target/linux/ath79/nand/profiles/00-default.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+ PRIORITY := 1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/nand/target.mk b/target/linux/ath79/nand/target.mk
new file mode 100644
index 0000000000..a53603d27b
--- /dev/null
+++ b/target/linux/ath79/nand/target.mk
@@ -0,0 +1,7 @@
+BOARDNAME := Generic devices with NAND flash
+FEATURES += squashfs nand rtc
+
+define Target/Description
+ Build firmware for Atheros AR71xx/AR913x based boards with
+ NAND flash, e.g. Netgear WNDR4300.
+endef