aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/nand
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-05-29 03:02:59 -0500
committerJohn Crispin <john@phrozen.org>2018-06-18 20:29:38 +0200
commit0e81968ee8def1d477f12d1eeb63f485c551463e (patch)
treebe167a805c372dadce271b9352c884152e0a9cb7 /target/linux/ath79/nand
parentfe3b62bbdc66a50c985ba3b0c9e873e5c0862ee2 (diff)
downloadupstream-0e81968ee8def1d477f12d1eeb63f485c551463e.tar.gz
upstream-0e81968ee8def1d477f12d1eeb63f485c551463e.tar.bz2
upstream-0e81968ee8def1d477f12d1eeb63f485c551463e.zip
ath79: add initial nand support for gl-ar300m
Signed-off-by: Marty E. Plummer <hanetzer@startmail.com>
Diffstat (limited to 'target/linux/ath79/nand')
-rw-r--r--target/linux/ath79/nand/config-default14
-rw-r--r--target/linux/ath79/nand/profiles/00-default.mk18
-rw-r--r--target/linux/ath79/nand/target.mk7
3 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ath79/nand/config-default b/target/linux/ath79/nand/config-default
new file mode 100644
index 0000000000..738c29c9b1
--- /dev/null
+++ b/target/linux/ath79/nand/config-default
@@ -0,0 +1,14 @@
+CONFIG_BCH=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_BCH=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_ECC_BCH=y
+CONFIG_MTD_SPINAND_MT29F=y
+CONFIG_MTD_SPINAND_ONDIEECC=y
+CONFIG_MTD_UBI=y
+CONFIG_MTD_UBI_BEB_LIMIT=20
+# CONFIG_MTD_UBI_BLOCK is not set
+# CONFIG_MTD_UBI_FASTMAP is not set
+# CONFIG_MTD_UBI_GLUEBI is not set
+CONFIG_MTD_UBI_WL_THRESHOLD=4096
+# CONFIG_UBIFS_FS is not set
diff --git a/target/linux/ath79/nand/profiles/00-default.mk b/target/linux/ath79/nand/profiles/00-default.mk
new file mode 100644
index 0000000000..06ab790389
--- /dev/null
+++ b/target/linux/ath79/nand/profiles/00-default.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+ PRIORITY := 1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/nand/target.mk b/target/linux/ath79/nand/target.mk
new file mode 100644
index 0000000000..a53603d27b
--- /dev/null
+++ b/target/linux/ath79/nand/target.mk
@@ -0,0 +1,7 @@
+BOARDNAME := Generic devices with NAND flash
+FEATURES += squashfs nand rtc
+
+define Target/Description
+ Build firmware for Atheros AR71xx/AR913x based boards with
+ NAND flash, e.g. Netgear WNDR4300.
+endef