aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 614f9ff0b2..d5fbd89c26 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -50,6 +50,24 @@ define Build/cybertan-trx
-rm $@-empty.bin
endef
+define Build/edimax-headers
+ $(eval edimax_magic=$(word 1,$(1)))
+ $(eval edimax_model=$(word 2,$(1)))
+
+ $(STAGING_DIR_HOST)/bin/edimax_fw_header -M $(edimax_magic) -m $(edimax_model)\
+ -v $(VERSION_DIST)$(firstword $(subst +, , $(firstword $(subst -, ,$(REVISION))))) \
+ -n "uImage" \
+ -i $(KDIR)/loader-$(DEVICE_NAME).uImage \
+ -o $@.uImage
+ $(STAGING_DIR_HOST)/bin/edimax_fw_header -M $(edimax_magic) -m $(edimax_model)\
+ -v $(VERSION_DIST)$(firstword $(subst +, , $(firstword $(subst -, ,$(REVISION))))) \
+ -n "rootfs" \
+ -i $@ \
+ -o $@.rootfs
+ cat $@.uImage $@.rootfs > $@
+ rm -rf $@.uImage $@.rootfs
+endef
+
# This needs to make /tmp/_sys/sysupgrade.tgz an empty file prior to
# sysupgrade, as otherwise it will implant the old configuration from
# OEM firmware when writing rootfs from factory.bin
@@ -363,6 +381,27 @@ define Device/avm_fritzdvbc
endef
TARGET_DEVICES += avm_fritzdvbc
+define Device/belkin_f9j1108-v2
+ SOC := qca9558
+ DEVICE_VENDOR := Belkin
+ DEVICE_MODEL := F9J1108 v2 (AC1750 DB Wi-Fi)
+ IMAGE_SIZE := 14464k
+ DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct kmod-usb2 \
+ kmod-usb3 kmod-usb-ledtrig-usbport
+ LOADER_TYPE := bin
+ LOADER_FLASH_OFFS := 0x50000
+ COMPILE := loader-$(1).bin loader-$(1).uImage
+ COMPILE/loader-$(1).bin := loader-okli-compile
+ COMPILE/loader-$(1).uImage := append-loader-okli $(1) | pad-to 64k | \
+ lzma | uImage lzma
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
+ edimax-headers F9J1108v1 BR-6679BAC | pad-to $$$$(BLOCKSIZE)
+endef
+TARGET_DEVICES += belkin_f9j1108-v2
+
define Device/buffalo_bhr-4grv
$(Device/buffalo_common)
SOC := ar7242