aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/Makefile2
-rw-r--r--target/linux/ath79/image/common-netgear.mk4
-rw-r--r--target/linux/ath79/image/common-tp-link.mk4
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk2
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk4
-rw-r--r--target/linux/ath79/image/generic.mk76
-rw-r--r--target/linux/ath79/image/mikrotik.mk2
-rw-r--r--target/linux/ath79/image/nand.mk8
-rw-r--r--target/linux/ath79/image/tiny-netgear.mk2
-rw-r--r--target/linux/ath79/image/tiny.mk4
10 files changed, 54 insertions, 54 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index c568c7238c..529baf8f57 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -65,7 +65,7 @@ define Device/Default
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-rootfs | pad-rootfs | append-metadata | check-size
endef
ifeq ($(SUBTARGET),generic)
diff --git a/target/linux/ath79/image/common-netgear.mk b/target/linux/ath79/image/common-netgear.mk
index 8fa6b030fc..51808069e3 100644
--- a/target/linux/ath79/image/common-netgear.mk
+++ b/target/linux/ath79/image/common-netgear.mk
@@ -38,7 +38,7 @@ define Device/netgear_ath79
KERNEL := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
IMAGES += factory.img
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
endef
diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
index 5b27390c1b..328eaaed30 100644
--- a/target/linux/ath79/image/common-tp-link.mk
+++ b/target/linux/ath79/image/common-tp-link.mk
@@ -31,7 +31,7 @@ define Device/tplink-v2
KERNEL := kernel-bin | append-dtb | lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | tplink-v2-header
IMAGE/sysupgrade.bin := tplink-v2-image -s | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
endef
define Device/tplink-nolzma
@@ -79,7 +79,7 @@ define Device/tplink-safeloader
TPLINK_HWREV := 0x0
KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
endef
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 18f5233c09..4c925cf850 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -541,7 +541,7 @@ define Device/tplink_tl-wr2543-v1
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
TPLINK_HWID := 0x25430001
IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade -v 3.13.99 | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
IMAGE/factory.bin := tplink-v1-image factory -v 3.13.99
SUPPORTED_DEVICES += tl-wr2543n
endef
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 95853b6c46..d2c4f73797 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -34,7 +34,7 @@ define Device/ubnt
DEVICE_PACKAGES := kmod-usb2
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | mkubntimage-split
+ append-rootfs | pad-rootfs | check-size | mkubntimage-split
endef
define Device/ubnt-bz
@@ -251,7 +251,7 @@ define Device/ubnt_routerstation_common
IMAGE_SIZE := 16128k
IMAGES := factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | mkubntimage | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
KERNEL_INITRAMFS := kernel-bin | append-dtb
endef
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 3ce51cc0d6..aac89e9269 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -99,9 +99,9 @@ define Device/seama
# - 36 bytes of META data (4-bytes aligned)
IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | seama | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
IMAGE/factory.bin := $$(IMAGE/default) | pad-rootfs -x 64 | seama | \
- seama-seal | check-size $$$$(IMAGE_SIZE)
+ seama-seal | check-size
SEAMA_SIGNATURE :=
endef
@@ -127,7 +127,7 @@ define Device/adtran_bsap1880
IMAGE/kernel.bin := append-kernel
IMAGE/rootfs.bin := append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
- check-size $$$$(IMAGE_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
+ check-size | sysupgrade-tar rootfs=$$$$@ | append-metadata
endef
define Device/adtran_bsap1800-v2
@@ -171,7 +171,7 @@ define Device/avm_fritz300e
IMAGE_SIZE := 15232k
IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | \
append-squashfs-fakeroot-be | pad-to 256 | append-rootfs | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
DEVICE_PACKAGES := fritz-tffs rssileds -swconfig
SUPPORTED_DEVICES += fritz300e
endef
@@ -186,7 +186,7 @@ define Device/avm_fritz4020
KERNEL_INITRAMFS := $$(KERNEL)
IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | \
append-squashfs-fakeroot-be | pad-to 256 | append-rootfs | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
DEVICE_PACKAGES := fritz-tffs
SUPPORTED_DEVICES += fritz4020
endef
@@ -200,7 +200,7 @@ define Device/buffalo_bhr-4grv
IMAGE_SIZE := 32256k
IMAGES += factory.bin tftp.bin
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ pad-rootfs | check-size
IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc BHR-4GRV 1.99 | \
buffalo-tag BHR-4GRV 3
IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
@@ -223,7 +223,7 @@ define Device/buffalo_wzr-hp-ag300h
IMAGE_SIZE := 32320k
IMAGES += factory.bin tftp.bin
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ pad-rootfs | check-size
IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WZR-HP-AG300H 1.99 | \
buffalo-tag WZR-HP-AG300H 3
IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
@@ -242,7 +242,7 @@ define Device/buffalo_wzr-hp-g302h-a1a0
IMAGE_SIZE := 32128k
IMAGES += factory.bin tftp.bin
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ pad-rootfs | check-size
IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WZR-HP-G302H 1.99 | \
buffalo-tag WZR-HP-G302H 4
IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
@@ -258,7 +258,7 @@ define Device/buffalo_wzr-hp-g450h
IMAGE_SIZE := 32256k
IMAGES += factory.bin tftp.bin
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ pad-rootfs | check-size
IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WZR-HP-G450H 1.99 | \
buffalo-tag WZR-HP-G450H 3
IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
@@ -426,7 +426,7 @@ define Device/dlink_dir-825-b1
DEVICE_VARIANT := B1
IMAGE_SIZE := 6208k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
kmod-leds-reset kmod-owl-loader
SUPPORTED_DEVICES += dir-825-b1
@@ -446,9 +446,9 @@ define Device/dlink_dir-825-c1
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
pad-rootfs
IMAGE/factory.bin := $$(IMAGE/default) | pad-offset $$$$(IMAGE_SIZE) 26 | \
- append-string 00DB120AR9344-RT-101214-00 | check-size $$$$(IMAGE_SIZE)
+ append-string 00DB120AR9344-RT-101214-00 | check-size
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
endef
TARGET_DEVICES += dlink_dir-825-c1
@@ -464,9 +464,9 @@ define Device/dlink_dir-835-a1
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
pad-rootfs
IMAGE/factory.bin := $$(IMAGE/default) | pad-offset $$$$(IMAGE_SIZE) 26 | \
- append-string 00DB120AR9344-RT-101214-00 | check-size $$$$(IMAGE_SIZE)
+ append-string 00DB120AR9344-RT-101214-00 | check-size
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
endef
TARGET_DEVICES += dlink_dir-835-a1
@@ -485,9 +485,9 @@ define Device/dlink_dir-842-c
IMAGE/default := append-kernel | uImage lzma | \
pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | seama | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
IMAGE/factory.bin := $$(IMAGE/default) | pad-rootfs -x 64 | seama | \
- seama-seal | check-size $$$$(IMAGE_SIZE)
+ seama-seal | check-size
IMAGE_SIZE := 15680k
endef
@@ -561,10 +561,10 @@ define Device/engenius_ecb1750
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
IMAGE_SIZE := 15680k
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
senao-header -r 0x101 -p 0x6d -t 2
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
endef
TARGET_DEVICES += engenius_ecb1750
@@ -576,7 +576,7 @@ define Device/engenius_epg5000
IMAGE_SIZE := 14656k
IMAGES += factory.dlf
IMAGE/factory.dlf := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
senao-header -r 0x101 -p 0x71 -t 2
SUPPORTED_DEVICES += epg5000
endef
@@ -694,7 +694,7 @@ define Device/iodata_wn-ac1167dgr
IMAGE_SIZE := 14656k
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
senao-header -r 0x30a -p 0x61 -t 2
DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
endef
@@ -707,7 +707,7 @@ define Device/iodata_wn-ac1600dgr
IMAGE_SIZE := 14656k
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
senao-header -r 0x30a -p 0x60 -t 2 -v 200
DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
endef
@@ -720,7 +720,7 @@ define Device/iodata_wn-ac1600dgr2
IMAGE_SIZE := 14656k
IMAGES += dgr2-dgr3-factory.bin
IMAGE/dgr2-dgr3-factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
senao-header -r 0x30a -p 0x60 -t 2 -v 200
DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
endef
@@ -733,7 +733,7 @@ define Device/iodata_wn-ag300dgr
IMAGE_SIZE := 15424k
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
senao-header -r 0x30a -p 0x47 -t 2
DEVICE_PACKAGES := kmod-usb2
endef
@@ -774,9 +774,9 @@ define Device/nec_wg1200cr
IMAGES += factory.bin
IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | seama | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
IMAGE/factory.bin := $$(IMAGE/default) | pad-rootfs -x 64 | seama | \
- seama-seal | nec-enc 9gsiy9nzep452pad | check-size $$$$(IMAGE_SIZE)
+ seama-seal | nec-enc 9gsiy9nzep452pad | check-size
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
endef
TARGET_DEVICES += nec_wg1200cr
@@ -788,7 +788,7 @@ define Device/nec_wg800hp
IMAGE_SIZE := 7104k
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
xor-image -p 6A57190601121E4C004C1E1201061957 -x | nec-fw LASER_ATERM
DEVICE_PACKAGES := kmod-ath10k-ct-smallbuffers ath10k-firmware-qca9887-ct-htt
endef
@@ -836,7 +836,7 @@ define Device/netgear_wndr3700
IMAGE_SIZE := 7680k
IMAGES += factory-NA.img
IMAGE/factory-NA.img := $$(IMAGE/default) | netgear-dni NA | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
SUPPORTED_DEVICES += wndr3700
endef
TARGET_DEVICES += netgear_wndr3700
@@ -893,7 +893,7 @@ define Device/netgear_wnr2200-8m
IMAGE_SIZE := 7808k
IMAGES += factory-NA.img
IMAGE/factory-NA.img := $$(IMAGE/default) | netgear-dni NA | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
SUPPORTED_DEVICES += wnr2200
endef
TARGET_DEVICES += netgear_wnr2200-8m
@@ -917,7 +917,7 @@ define Device/ocedo_koala
SUPPORTED_DEVICES += koala
IMAGE_SIZE := 7424k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
endef
TARGET_DEVICES += ocedo_koala
@@ -927,7 +927,7 @@ define Device/ocedo_raccoon
DEVICE_MODEL := Raccoon
IMAGE_SIZE := 7424k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
endef
TARGET_DEVICES += ocedo_raccoon
@@ -938,7 +938,7 @@ define Device/ocedo_ursus
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
IMAGE_SIZE := 7424k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
endef
TARGET_DEVICES += ocedo_ursus
@@ -987,7 +987,7 @@ define Device/phicomm_k2t
DEVICE_MODEL := K2T
IMAGE_SIZE := 15744k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
DEVICE_PACKAGES := kmod-leds-reset kmod-ath10k-ct-smallbuffers ath10k-firmware-qca9888-ct
endef
TARGET_DEVICES += phicomm_k2t
@@ -1075,7 +1075,7 @@ define Device/sitecom_wlr-7100
DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct-smallbuffers kmod-usb2
IMAGES += factory.dlf
IMAGE/factory.dlf := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
senao-header -r 0x222 -p 0x53 -t 2
IMAGE_SIZE := 7488k
endef
@@ -1091,7 +1091,7 @@ define Device/sitecom_wlr-8100
SUPPORTED_DEVICES += wlr8100
IMAGES += factory.dlf
IMAGE/factory.dlf := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ append-rootfs | pad-rootfs | check-size | \
senao-header -r 0x222 -p 0x56 -t 2
IMAGE_SIZE := 15424k
endef
@@ -1112,10 +1112,10 @@ define Device/teltonika_rut955
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs |\
pad-rootfs | teltonika-fw-fake-checksum | append-string master |\
- append-md5sum-bin | check-size $$$$(IMAGE_SIZE)
+ append-md5sum-bin | check-size
IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
append-rootfs | pad-rootfs | append-metadata |\
- check-size $$$$(IMAGE_SIZE)
+ check-size
endef
TARGET_DEVICES += teltonika_rut955
@@ -1131,9 +1131,9 @@ define Device/trendnet_tew-823dru
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
pad-rootfs
IMAGE/factory.bin := $$(IMAGE/default) | pad-offset $$$$(IMAGE_SIZE) 26 | \
- append-string 00AP135AR9558-RT-131129-00 | check-size $$$$(IMAGE_SIZE)
+ append-string 00AP135AR9558-RT-131129-00 | check-size
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
endef
TARGET_DEVICES += trendnet_tew-823dru
diff --git a/target/linux/ath79/image/mikrotik.mk b/target/linux/ath79/image/mikrotik.mk
index a89dc8c170..a9ff129816 100644
--- a/target/linux/ath79/image/mikrotik.mk
+++ b/target/linux/ath79/image/mikrotik.mk
@@ -19,7 +19,7 @@ define Device/mikrotik_routerboard-wap-g-5hact2hnd
IMAGE_SIZE := 16256k
IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 -e | \
pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
SUPPORTED_DEVICES += rb-wapg-5hact2hnd
endef
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 7d283b54c4..3ccd19914f 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -43,7 +43,7 @@ define Device/aerohive_hiveap-121
SUPPORTED_DEVICES += hiveap-121
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
TARGET_DEVICES += aerohive_hiveap-121
@@ -62,7 +62,7 @@ define Device/domywifi_dw33d
IMAGES += factory.bin
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
endef
TARGET_DEVICES += domywifi_dw33d
@@ -145,9 +145,9 @@ define Device/netgear_ath79_nand
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
IMAGES := sysupgrade.bin factory.img
IMAGE/factory.img := append-kernel | append-ubi | netgear-dni | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
UBINIZE_OPTS := -E 5
endef
diff --git a/target/linux/ath79/image/tiny-netgear.mk b/target/linux/ath79/image/tiny-netgear.mk
index 591ea57222..5c83a10e01 100644
--- a/target/linux/ath79/image/tiny-netgear.mk
+++ b/target/linux/ath79/image/tiny-netgear.mk
@@ -56,7 +56,7 @@ define Device/netgear_wnr2000-v3
append-rootfs | pad-rootfs
IMAGES += factory-NA.img
IMAGE/factory-NA.img := $$(IMAGE/default) | netgear-dni NA | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
SUPPORTED_DEVICES += wnr2000-v3
$(Device/netgear_ath79)
endef
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index 54b20b6089..41f1eb4305 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -7,7 +7,7 @@ define Device/buffalo_whr-g301n
IMAGE_SIZE := 3712k
IMAGES += factory.bin tftp.bin
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ pad-rootfs | check-size
IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WHR-G301N 1.99 | \
buffalo-tag WHR-G301N 3
IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
@@ -25,7 +25,7 @@ define Device/dlink_dir-615-e4
IMAGES += factory.bin
IMAGE/default := append-kernel | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
IMAGE/factory.bin := $$(IMAGE/default) | \
check-size $$$$(FACTORY_IMAGE_SIZE) | pad-to $$$$(FACTORY_IMAGE_SIZE) | \
append-string "AP99-AR7240-RT-091105-05"