aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/nand.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/nand.mk')
-rw-r--r--target/linux/ath79/image/nand.mk21
1 files changed, 17 insertions, 4 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 726fab068f..1d086b1918 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -305,7 +305,7 @@ define Device/netgear_wndr4500-v3
endef
TARGET_DEVICES += netgear_wndr4500-v3
-define Device/zte_mf286_common
+define Device/zte_mf28x_common
SOC := qca9563
DEVICE_VENDOR := ZTE
DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct
@@ -315,8 +315,21 @@ define Device/zte_mf286_common
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
+define Device/zte_mf281
+ $(Device/zte_mf28x_common)
+ DEVICE_MODEL := MF281
+ KERNEL_SIZE := 6144k
+ IMAGE_SIZE := 29696k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
+ check-size
+ DEVICE_PACKAGES += ath10k-firmware-qca9888-ct kmod-usb-net-rndis \
+ kmod-usb-acm comgt-ncm
+endef
+TARGET_DEVICES += zte_mf281
+
define Device/zte_mf286
- $(Device/zte_mf286_common)
+ $(Device/zte_mf28x_common)
DEVICE_MODEL := MF286
DEVICE_PACKAGES += ath10k-firmware-qca988x-ct kmod-usb-net-qmi-wwan \
kmod-usb-serial-option uqmi
@@ -324,7 +337,7 @@ endef
TARGET_DEVICES += zte_mf286
define Device/zte_mf286a
- $(Device/zte_mf286_common)
+ $(Device/zte_mf28x_common)
DEVICE_MODEL := MF286A
DEVICE_PACKAGES += ath10k-firmware-qca9888-ct kmod-usb-net-qmi-wwan \
kmod-usb-serial-option uqmi
@@ -332,7 +345,7 @@ endef
TARGET_DEVICES += zte_mf286a
define Device/zte_mf286r
- $(Device/zte_mf286_common)
+ $(Device/zte_mf28x_common)
DEVICE_MODEL := MF286R
DEVICE_PACKAGES += ath10k-firmware-qca9888-ct kmod-usb-net-rndis kmod-usb-acm \
comgt-ncm