aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b3eaee48b7..eb71c641a0 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -13,6 +13,19 @@ define Device/avm_fritz300e
endef
TARGET_DEVICES += avm_fritz300e
+define Device/avm_fritz4020
+ ATH_SOC := qca9561
+ DEVICE_TITLE := AVM FRITZ!Box 4020
+ IMAGE_SIZE := 15232k
+ KERNEL := kernel-bin | append-dtb | lzma | eva-image
+ KERNEL_INITRAMFS := $$(KERNEL)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | \
+ append-squashfs-fakeroot-be | pad-to 256 | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ DEVICE_PACKAGES := fritz-tffs
+endef
+TARGET_DEVICES += avm_fritz4020
+
define Device/buffalo_wzr-hp-g450h
ATH_SOC := ar7242
DEVICE_TITLE := Buffalo WZR-HP-G450H