aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 86aae57266..4d3f455e49 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1900,6 +1900,43 @@ define Device/plasmacloud_pa300e
endef
TARGET_DEVICES += plasmacloud_pa300e
+define Device/qca_ap143
+ SOC := qca9533
+ DEVICE_VENDOR := Qualcomm Atheros
+ DEVICE_MODEL := AP143
+ DEVICE_PACKAGES := kmod-usb2
+ SUPPORTED_DEVICES += ap143
+ LOADER_TYPE := bin
+ LOADER_FLASH_OFFS := 0x50000
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49
+ COMPILE := loader-$(1).bin loader-$(1).uImage
+ COMPILE/loader-$(1).bin := loader-okli-compile
+ COMPILE/loader-$(1).uImage := append-loader-okli $(1) | pad-to 64k | lzma | \
+ uImage lzma
+endef
+
+define Device/qca_ap143-8m
+ $(Device/qca_ap143)
+ DEVICE_VARIANT := (8M)
+ IMAGE_SIZE := 7744k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | pad-to 6336k | \
+ append-loader-okli-uimage $(1) | pad-to 64k
+endef
+TARGET_DEVICES += qca_ap143-8m
+
+define Device/qca_ap143-16m
+ $(Device/qca_ap143)
+ DEVICE_VARIANT := (16M)
+ IMAGE_SIZE := 15936k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | pad-to 14528k | \
+ append-loader-okli-uimage $(1) | pad-to 64k
+endef
+TARGET_DEVICES += qca_ap143-16m
+
define Device/qihoo_c301
$(Device/seama)
SOC := ar9344